(HDU2020 C++) 绝对值排序

绝对值排序

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 99253 Accepted Submission(s): 46879

Problem Description

输入n(n<=100)个整数,按照绝对值从大到小排序后输出。题目保证对于每一个测试实例,所有的数的绝对值都不相等。

Input

输入数据有多组,每组占一行,每行的第一个数字为n,接着是n个整数,n=0表示输入数据的结束,不做处理。

Output

对于每个测试实例,输出排序后的结果,两个数之间用一个空格隔开。每个测试实例占一行。

Sample Input

3 3 -4 2
4 0 1 2 -3
0

Sample Output

-4 3 2
-3 2 1 0

********************************************/

解题思路:
和一般的排序相比,就是在比较时,对两个被比较数求绝对值math.h中的abs()函数求绝对值

注意:
输出格式:除最后一个元素后面不加空格加换行外,其他元素后面加空格。

#include<iostream>
#include<math.h>
using namespace std;
int main()
{
    int n, a[100];
    while (cin >> n&&n != 0)
    {
        for (int i = 0; i < n; i++)
            cin >> a[i];
        for (int i = 0; i < n - 1; i++)
        {
            for (int j = i + 1; j < n; j++)
            {
                if (abs(a[i]) < abs(a[j]))
                {
                    int c = a[i];
                    a[i] = a[j];
                    a[j] = c;
                }
            }
        }
        for (int i = 0; i < n; i++)
        {
            if (i != 0)
                cout << " ";
            cout << a[i];
        }
        cout << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38780240/article/details/81537609