HDU绝对值排序

Problem Description

输入n(n<=100)个整数,按照绝对值从大到小排序后输出。题目保证对于每一个测试实例,所有的数的绝对值都不相等。

Input

输入数据有多组,每组占一行,每行的第一个数字为n,接着是n个整数,n=0表示输入数据的结束,不做处理。

Output

对于每个测试实例,输出排序后的结果,两个数之间用一个空格隔开。每个测试实例占一行

Sample Input

 

3 3 -4 2 4 0 1 2 -3 0

Sample Output

 

-4 3 2 -3 2 1 0

#include<stdio.h>
#include<math.h>
int main()
{
	int i,j,n,t,a[110];
	while(scanf("%d",&n),n != 0)
	{
		for(i = 1; i <= n; i ++)
			scanf("%d",&a[i]);
			
		for(i = 1; i < n; i ++)
			for(j = 1; j <= n-i; j ++)
				if(fabs(a[j]) < fabs(a[j+1]))
				{
					t = a[j];
					a[j] = a[j+1];
					a[j+1] = t;
				}
		for(i = 1; i < n; i ++)
			printf("%d ",a[i]);
		printf("%d\n",a[n]); 
	}
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/queen00000/article/details/81088453