绝对值排序 (排序)

https://vjudge.net/contest/352887#problem/B

输入n(n<=100)个整数,按照绝对值从大到小排序后输出。题目保证对于每一个测试实例,所有的数的绝对值都不相等。

Input

输入数据有多组,每组占一行,每行的第一个数字为n,接着是n个整数,n=0表示输入数据的结束,不做处理。

Output

对于每个测试实例,输出排序后的结果,两个数之间用一个空格隔开。每个测试实例占一行。

Sample Input

3 3 -4 2
4 0 1 2 -3
0

Sample Output

-4 3 2
-3 2 1 0
import java.util.*;
public class Main {
	static Scanner sc=new Scanner(System.in);
	static class node{
		int x;
		public node(int x){
			this.x=x;
		}
	}
	static Comparator<node> cmp=new Comparator<node>(){
		public int compare(node a,node b) {
			return Math.abs(b.x)-Math.abs(a.x); 
		}
	};
	static node[] a=new node[105];
	
	public static void main(String[] args) {
		int n;
		while(sc.hasNext()) {
			n=sc.nextInt();
			if(n==0) break;
			for(int i=1;i<=n;i++) a[i]=new node(sc.nextInt());
			Arrays.sort(a,1,1+n,cmp);
			for(int i=1;i<=n;i++) {
				System.out.print(a[i].x);
				if(i!=n) System.out.print(" ");
				else System.out.println();
			}
		}
	}
}
发布了428 篇原创文章 · 获赞 55 · 访问量 5万+

猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/104065765