hdu_problem_2026_首字母变大写

/*
*
*Problem Description
*输入一个英文句子,将每个单词的第一个字母改成大写字母。
*
*
*Input
*输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
*
*
*Output
*请输出按照要求改写后的英文句子。
*
*
*Sample Input
*i like acm
*i want to get an accepted
*
*
*Sample Output
*I Like Acm
*I Want To Get An Accepted
*
*
*Author
*lcy
*
*
*Source
*C语言程序设计练习(四)
*
*
*Recommend
*lcy
*
*/
#include<iostream>
#include<string>
using namespace std;
int main() {
 string s;
 char x;
 while (getline(cin, s)) {
  s.at(0) -= 32;
  for (int i = 1; i < s.size(); i++) {
   if (s.at(i - 1) == ' ') s.at(i) -= 32;
  }
  cout << s << endl;
 }
 system("pause");
 return 0;
}

猜你喜欢

转载自blog.csdn.net/CoderMaximum/article/details/86570829