HDU-2026 首字母变大写

Problem Description

输入一个英文句子,将每个单词的第一个字母改成大写字母。

Input

输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行

Output

请输出按照要求改写后的英文句子。

Sample Input

i like acm

i want to get an accepted

Sample Output

I Like Acm

I Want To Get An Accepted

代码:

#include <stdio.h>
#include <string.h>
int main()
{
	int l,i,j;
	char a[120];
    while(gets(a)!=NULL)
    {
        l=strlen(a);
        for(i=0;i<l;i++)
        {
            if(a[i]==' ')
            {
                j=i+1;
                a[j]=a[j]-32;
            }
            if(i==0)
                a[i]=a[i]-32;
            printf("%c",a[i]);
        }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hello_cmy/article/details/82112973