杭电oj首字母变大写

Problem Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。
 
Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
 
Output
请输出按照要求改写后的英文句子。
 
Sample Input
 
 
i like acm i want to get an accepted
 
Sample Output
 
 
I Like Acm I Want To Get An Accepted

ac代码:

 #include<iostream>
 #include<cstdio>
 #include<cstring>
 #include<cctype>
 using namespace std;
 int main()
 {
     char a[101];
     while(gets(a))
     {
         a[0]-=32;
         for(int i=1;i<strlen(a);i++)
         {
             if(a[i-1]==' ')
                a[i]-=32;
         }
         puts(a);
     }
         return 0;
 }

猜你喜欢

转载自www.cnblogs.com/bejm/p/9101617.html