HDoj 2026 首字母变大写

Problem Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。
 
Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
 
Output
请输出按照要求改写后的英文句子。
 
Sample Input
i like acm i want to get an accepted
 
Sample Output
I Like Acm I Want To Get An Accepted
 
Author
lcy
 
Source
 
Recommend
lcy   |   We have carefully selected several similar problems for you:   2027  2043  2031  2030  2033 
 
 
 
含有空格的字符串可以用gets()接受,
char *gets(char *str);
在终止测试用例的输入时返回的不是EOF而是0
 
C语言代码如下:
 #include<stdio.h>
 int main()
 {
     char s[100];
     while(gets(s)!=0)
     {
         s[0]-=32;
         for(int i=0;s[i]!='\0';i++)
            if(s[i]==' ')
                s[i+1]-=32;
         printf("%s\n",s);
     }
 }

猜你喜欢

转载自www.cnblogs.com/wzmm/p/12583634.html