1020. Tree Traversals (25) [二叉树的遍历,后序中序转层序]

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7

2 3 1 5 7 6 4

1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <string>
#include <cctype>
#include <string.h>
#include <cstdio>
using namespace std;
struct node{
    int index,value;
};
bool cmp(node a,node b){
    return a.index<b.index;
}
vector<int> post,in;
vector<node> ans;
void pre(int root,int start,int end,int index){
    if(start>end) return;
    int i=start;
    while(i<end&&in[i]!=post[root]) i++;
    ans.push_back({index,post[root]});//顺序要一致
    pre(root-(end-i+1),start,i-1,2*index+1);
    pre(root-1,i+1,end,2*index+2);
}
int main(){
    int n;
    cin>>n;
    post.resize(n);
    in.resize(n);
    for(int i=0;i<n;i++) cin>>post[i];
    for(int i=0;i<n;i++) cin>>in[i];
    pre(n-1,0,n-1,0);
    sort(ans.begin(),ans.end(),cmp);
    for(int i=0;i<ans.size();i++){
        if(i) cout<<" ";
        cout<<ans[i].value;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42068614/article/details/86550589