【HDU】1756Cupid's Arrow(判断:点在多边形内 模板题目)

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3177    Accepted Submission(s): 1142


 

Problem Description

传说世上有一支丘比特的箭,凡是被这支箭射到的人,就会深深的爱上射箭的人。
世上无数人都曾经梦想得到这支箭。Lele当然也不例外。不过他想,在得到这支箭前,他总得先学会射箭。
日子一天天地过,Lele的箭术也越来越强,渐渐得,他不再满足于去射那圆形的靶子,他开始设计各种各样多边形的靶子。
不过,这样又出现了新的问题,由于长时间地练习射箭,Lele的视力已经高度近视,他现在甚至无法判断他的箭射到了靶子没有。所以他现在只能求助于聪明的Acmers,你能帮帮他嘛?

 

Input

本题目包含多组测试,请处理到文件结束。
在每组测试的第一行,包含一个正整数N(2<N<100),表示靶子的顶点数。
接着N行按顺时针方向给出这N个顶点的x和y坐标(0<x,y<1000)。
然后有一个正整数M,表示Lele射的箭的数目。
接下来M行分别给出Lele射的这些箭的X,Y坐标(0<X,Y<1000)。

 

Output

对于每枝箭,如果Lele射中了靶子,就在一行里面输出"Yes",否则输出"No"。

 

Sample Input

 

4 10 10 20 10 20 5 10 5 2 15 8 25 8

 

Sample Output

 

Yes No

 

Author

linle

 

Source

2007省赛集训队练习赛(6)_linle专场

 

Recommend

lcy

中文题目,

代码:

#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
const double eps=1e-10;
const int maxn=1000+10;
int dcmp(double x)
{
    if(fabs(x)<eps) return 0;
    return x<0?-1:1;
}
struct Point
{
    double x,y;
    Point(){}
    Point(double x,double y):x(x),y(y){}
};
typedef Point Vector;
Vector operator-(Point A,Point B)
{
    return Vector(A.x-B.x,A.y-B.y);
}
double Dot(Vector A,Vector B)
{
    return A.x*B.x+A.y*B.y;
}
double Cross(Vector A,Vector B)
{
    return A.x*B.y-A.y*B.x;
}
bool InSegment(Point P,Point A,Point B)
{
    return dcmp( Cross(A-B,P-B) )==0 && dcmp( Dot(A-P,B-P) )<=0;
}
bool PointInPolygon(Point p,Point*poly,int n)
{
    int wn=0;
    for(int i=0;i<n;++i)
    {
        if(InSegment(p,poly[i],poly[(i+1)%n])) return true;
        int k=dcmp( Cross(poly[(i+1)%n]-poly[i], p-poly[i] ) );
        int d1=dcmp( poly[i].y-p.y );
        int d2=dcmp( poly[(i+1)%n].y-p.y );
        if(k>0 && d1<=0 && d2>0) wn++;
        if(k<0 && d2<=0 && d1>0) wn--;
    }
    if(wn!=0) return true;
    return false;
}

int main()
{
    int n;
    while(scanf("%d",&n)==1 && n)
    {
        Point poly[maxn],p;
        for(int i=0;i<n;++i)
            scanf("%lf%lf",&poly[i].x,&poly[i].y);
        int k;
        scanf("%d",&k);
        while(k--)
        {
            scanf("%lf%lf",&p.x,&p.y);
        printf("%s\n",PointInPolygon(p,poly,n)?"Yes":"No");
        }

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wentong_Xu/article/details/86514098
今日推荐