[HDU5023]A Corrupt Mayor's Performance Art

版权声明:辛辛苦苦码字,你们转载的时候记得告诉我 https://blog.csdn.net/dxyinme/article/details/86434442

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 100000/100000 K (Java/Others)

Problem Description

Corrupt governors always find ways to get dirty money. Paint something, then sell the worthless painting at a high price to someone who wants to bribe him/her on an auction, this seemed a safe way for mayor X to make money.

Because a lot of people praised mayor X’s painting(of course, X was a mayor), mayor X believed more and more that he was a very talented painter. Soon mayor X was not satisfied with only making money. He wanted to be a famous painter. So he joined the local painting associates. Other painters had to elect him as the chairman of the associates. Then his painting sold at better price.

The local middle school from which mayor X graduated, wanted to beat mayor X’s horse fart(In Chinese English, beating one’s horse fart means flattering one hard). They built a wall, and invited mayor X to paint on it. Mayor X was very happy. But he really had no idea about what to paint because he could only paint very abstract paintings which nobody really understand. Mayor X’s secretary suggested that he could make this thing not only a painting, but also a performance art work.

This was the secretary’s idea:

The wall was divided into N segments and the width of each segment was one cun(cun is a Chinese length unit). All segments were numbered from 1 to N, from left to right. There were 30 kinds of colors mayor X could use to paint the wall. They named those colors as color 1, color 2 … color 30. The wall’s original color was color 2. Every time mayor X would paint some consecutive segments with a certain kind of color, and he did this for many times. Trying to make his performance art fancy, mayor X declared that at any moment, if someone asked how many kind of colors were there on any consecutive segments, he could give the number immediately without counting.

But mayor X didn’t know how to give the right answer. Your friend, Mr. W was an secret officer of anti-corruption bureau, he helped mayor X on this problem and gained his trust. Do you know how Mr. Q did this?

Input

There are several test cases.

For each test case:

The first line contains two integers, N N and M M ,meaning that the wall is divided into N N segments and there are M M operations ( 0 < N < = 1 , 000 , 000 ; 0 < M < = 100 , 000 ) (0 < N <= 1,000,000; 0<M<=100,000)

Then M M lines follow, each representing an operation. There are two kinds of operations, as described below:

  1. P a b c
    a a , b b and c c are integers. This operation means that mayor X painted all segments from segment a to segment b with color c ( 0 < a < = b < = N , 0 < c < = 30 ) c ( 0 < a<=b <= N, 0 < c <= 30) .

  2. Q a b
    a a and b b are integers. This is a query operation. It means that someone asked that how many kinds of colors were there from segment a a to segment b ( 0 < a < = b < = N ) b ( 0 < a<=b <= N) .

Please note that the operations are given in time sequence.
The input ends with M = 0 M = 0 and N = 0 N = 0 .

Output

For each query operation, print all kinds of color on the queried segments. For color 1, print 1, for color 2, print 2 … etc. And this color sequence must be in ascending order.

Sample Input

5 10
P 1 2 3
P 2 3 4
Q 2 3
Q 1 3
P 3 5 4
P 1 2 7
Q 1 3
Q 3 4
P 5 5 8
Q 1 5
0 0

Sample Output

4
3 4
4 7
4
4 7 8

Source
2014 ACM/ICPC Asia Regional Guangzhou Online

题意:
两个操作,一共30种颜色,一堵墙上刚开始都是第二种颜色,
两个操作:
第一个:区间染色,
第二个:询问一个区间有哪些颜色

题解:
线段树,用一个数字表示当前区间的染色集合。用位运算维护
注意输出格式

#include<bits/stdc++.h>
#define LiangJiaJun main
using namespace std;
struct tree{
    int mask,tag;
    int l,r;
}tr[4000004];
int n,m;
void print(int mask){
     int g[34],cnt=0;
     for(int i=0;i<30;i++)if(mask&(1<<i))g[++cnt]=i+1;
     for(int i=1;i<cnt;i++)printf("%d ",g[i]);
     printf("%d\n",g[cnt]);
}
void build(int k,int l,int r){
     tr[k].tag=-1;
     tr[k].mask=(1<<1);
     tr[k].l=l;tr[k].r=r;
     if(l==r)return ;
     int mid=(l+r)>>1;
     build(k<<1,l,mid);
     build(k<<1|1,mid+1,r);
}
void pushdown(int k){
     if(tr[k].tag==-1)return ;
     int x=tr[k].tag;
     tr[k].tag=-1;
     tr[k<<1].tag=x;
     tr[k<<1].mask=(1<<x);
     tr[k<<1|1].tag=x;
     tr[k<<1|1].mask=(1<<x);
}
void change(int k,int a,int b,int c){
     int l=tr[k].l,r=tr[k].r;
     if(l==a&&r==b){
        tr[k].tag=c;
        tr[k].mask=(1<<c);
        return ;
     }
     pushdown(k);
     int mid=(l+r)>>1;
     if(b<=mid)change(k<<1,a,b,c);
     else if(a>mid)change(k<<1|1,a,b,c);
     else {
        change(k<<1,a,mid,c);
        change(k<<1|1,mid+1,b,c);
     }
     tr[k].mask=(tr[k<<1].mask|tr[k<<1|1].mask);
     return ;
}
int query(int k,int a,int b){
    int l=tr[k].l,r=tr[k].r;
    if(l==a&&r==b)return tr[k].mask;
    pushdown(k);
    int mid=(l+r)>>1;
    if(b<=mid)return query(k<<1,a,b);
    else if(a>mid)return query(k<<1|1,a,b);
    else{
        return (query(k<<1,a,mid)|query(k<<1|1,mid+1,b));
    }
}
int w33ha(){
    build(1,1,n);
    while(m--){
        int a,b;
        char ch[4];
        scanf("%s",ch+1);
        scanf("%d%d",&a,&b);
        if(ch[1]=='P'){
            int c;scanf("%d",&c);
            change(1,a,b,c-1);
        }
        if(ch[1]=='Q')print(query(1,a,b));
    }
    return 0;
}

int LiangJiaJun(){
    while(scanf("%d%d",&n,&m)!=EOF){
        if(n==0&&m==0)return 0;
        w33ha();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/dxyinme/article/details/86434442