HDU-5023A Corrupt Mayor's Performance Art(线段树+区间染色)**经典例题**

题目链接
Problem Description
Corrupt governors always find ways to get dirty money. Paint something, then sell the worthless painting at a high price to someone who wants to bribe him/her on an auction, this seemed a safe way for mayor X to make money.

Because a lot of people praised mayor X’s painting(of course, X was a mayor), mayor X believed more and more that he was a very talented painter. Soon mayor X was not satisfied with only making money. He wanted to be a famous painter. So he joined the local painting associates. Other painters had to elect him as the chairman of the associates. Then his painting sold at better price.

The local middle school from which mayor X graduated, wanted to beat mayor X’s horse fart(In Chinese English, beating one’s horse fart means flattering one hard). They built a wall, and invited mayor X to paint on it. Mayor X was very happy. But he really had no idea about what to paint because he could only paint very abstract paintings which nobody really understand. Mayor X’s secretary suggested that he could make this thing not only a painting, but also a performance art work.

This was the secretary’s idea:

The wall was divided into N segments and the width of each segment was one cun(cun is a Chinese length unit). All segments were numbered from 1 to N, from left to right. There were 30 kinds of colors mayor X could use to paint the wall. They named those colors as color 1, color 2 … color 30. The wall’s original color was color 2. Every time mayor X would paint some consecutive segments with a certain kind of color, and he did this for many times. Trying to make his performance art fancy, mayor X declared that at any moment, if someone asked how many kind of colors were there on any consecutive segments, he could give the number immediately without counting.

But mayor X didn’t know how to give the right answer. Your friend, Mr. W was an secret officer of anti-corruption bureau, he helped mayor X on this problem and gained his trust. Do you know how Mr. Q did this?

Input
There are several test cases.

For each test case:

The first line contains two integers, N and M ,meaning that the wall is divided into N segments and there are M operations(0 < N <= 1,000,000; 0<M<=100,000)

Then M lines follow, each representing an operation. There are two kinds of operations, as described below:

  1. P a b c
    a, b and c are integers. This operation means that mayor X painted all segments from segment a to segment b with color c ( 0 < a<=b <= N, 0 < c <= 30).

  2. Q a b
    a and b are integers. This is a query operation. It means that someone asked that how many kinds of colors were there from segment a to segment b ( 0 < a<=b <= N).

Please note that the operations are given in time sequence.

The input ends with M = 0 and N = 0.

Output
For each query operation, print all kinds of color on the queried segments. For color 1, print 1, for color 2, print 2 … etc. And this color sequence must be in ascending order.

Sample Input
5 10
P 1 2 3
P 2 3 4
Q 2 3
Q 1 3
P 3 5 4
P 1 2 7
Q 1 3
Q 3 4
P 5 5 8
Q 1 5
0 0

Sample Output
4
3 4
4 7
4
4 7 8

题意:给一长度为n的区间,区间中每个单位长度都有val。初始val都为2。有两种操作:改变某一区间里的所有val,询问某一区间的val,如果有多个val,从小到大输出(去重)。
如果子区间val一样,那么设父节点val=0.询问的时候写一个递归就可以找到val不为0的子区间,得到答案。
AC代码

#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <limits>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
using namespace std;
#define ll long long
#define lowbit(x) (x&(-x))
#define MT(a,b) memset(a,b,sizeof(a))
const int maxn=1E6+5;
const int ONF=-0x3f3f3f3f;
const int INF=0x3f3f3f3f;
int ans[maxn];
int cnt;
struct node
{
    int lazy,val;
}qwe[maxn<<2];
void update(int root)
{
    if (qwe[root<<1|1].val==qwe[root<<1].val)
        qwe[root].val=qwe[root<<1].val;
    else qwe[root].val=0;
}
void build_tree(int l,int r,int root)
{
    qwe[root].lazy=0;
    if (l==r){
        qwe[root].val=2;
        return;
    }
    int mid=(l+r)>>1;
    build_tree(l,mid,root<<1);
    build_tree(mid+1,r,root<<1|1);
    update(root);
}
void pushdown(int root)
{
    if (qwe[root].lazy==0)
        return;
    qwe[root<<1].lazy=qwe[root].lazy;
    qwe[root<<1|1].lazy=qwe[root].lazy;
    qwe[root<<1].val=qwe[root].lazy;
    qwe[root<<1|1].val=qwe[root].lazy;
    qwe[root].lazy=0;
}
void change(int l,int r,int ql,int qr,int root,int val)
{
    if (l==ql&&r==qr){
        qwe[root].val=val;
        qwe[root].lazy=val;
        return;
    }
    pushdown(root);
    int mid=(l+r)>>1;
    if (qr<=mid) change(l,mid,ql,qr,root<<1,val);
    else if (ql>mid) change(mid+1,r,ql,qr,root<<1|1,val);
    else{
        change(l,mid,ql,mid,root<<1,val);
        change(mid+1,r,mid+1,qr,root<<1|1,val);
    }
    update(root);
}
void getans(int root)
{
    if(qwe[root].val!=0){
        ans[++cnt]=qwe[root].val;
        return;
    }
    getans(root<<1);
    getans(root<<1|1);
}
void query(int l,int r,int ql,int qr,int root)
{
    if (l==ql&&r==qr){
        getans(root);
        return ;
    }
    pushdown(root);
    int mid=(l+r)>>1;
    if (qr<=mid) query(l,mid,ql,qr,root<<1);
    else if (ql>mid)  query(mid+1,r,ql,qr,root<<1|1);
    else {
         query(l,mid,ql,mid,root<<1);
         query(mid+1,r,mid+1,qr,root<<1|1);
    }
}
int main ()
{
    int a,b,c;
    int n,m;while (~scanf ("%d%d",&n,&m)){
        if (n==m&&n==0) break;
        build_tree(1,n,1);
        for (int i=1;i<=m;i++){
            char tmp[2];
            scanf ("%s",tmp);
            if (tmp[0]=='P'){
                scanf ("%d%d%d",&a,&b,&c);
                change(1,n,a,b,1,c);
            } else if (tmp[0]=='Q'){
                cnt=0;
                scanf ("%d%d",&a,&b);
                query(1,n,a,b,1);
                sort(ans+1,ans+1+cnt);
                int zhangjie=unique(ans+1,ans+1+cnt)-(ans+1);
                for (int j=1;j<=zhangjie;j++){
                    printf("%d",ans[j]);
                    if(j==zhangjie) printf("\n");
                    else printf(" ");
                }
            }
        }
    }
    return 0;
}
发布了33 篇原创文章 · 获赞 15 · 访问量 916

猜你喜欢

转载自blog.csdn.net/weixin_43925900/article/details/97484102