A Corrupt Mayor's Performance Art 线段树 hdu 5023

Problem Description
Corrupt governors always find ways to get dirty money. Paint something, then sell the worthless painting at a high price to someone who wants to bribe him/her on an auction, this seemed a safe way for mayor X to make money.

Because a lot of people praised mayor X’s painting(of course, X was a mayor), mayor X believed more and more that he was a very talented painter. Soon mayor X was not satisfied with only making money. He wanted to be a famous painter. So he joined the local painting associates. Other painters had to elect him as the chairman of the associates. Then his painting sold at better price.

The local middle school from which mayor X graduated, wanted to beat mayor X’s horse fart(In Chinese English, beating one’s horse fart means flattering one hard). They built a wall, and invited mayor X to paint on it. Mayor X was very happy. But he really had no idea about what to paint because he could only paint very abstract paintings which nobody really understand. Mayor X’s secretary suggested that he could make this thing not only a painting, but also a performance art work.

This was the secretary’s idea:

The wall was divided into N segments and the width of each segment was one cun(cun is a Chinese length unit). All segments were numbered from 1 to N, from left to right. There were 30 kinds of colors mayor X could use to paint the wall. They named those colors as color 1, color 2 … color 30. The wall’s original color was color 2. Every time mayor X would paint some consecutive segments with a certain kind of color, and he did this for many times. Trying to make his performance art fancy, mayor X declared that at any moment, if someone asked how many kind of colors were there on any consecutive segments, he could give the number immediately without counting.

But mayor X didn’t know how to give the right answer. Your friend, Mr. W was an secret officer of anti-corruption bureau, he helped mayor X on this problem and gained his trust. Do you know how Mr. Q did this?

Input
There are several test cases.

For each test case:

The first line contains two integers, N and M ,meaning that the wall is divided into N segments and there are M operations(0 < N <= 1,000,000; 0<M<=100,000)

Then M lines follow, each representing an operation. There are two kinds of operations, as described below:

  1. P a b c
    a, b and c are integers. This operation means that mayor X painted all segments from segment a to segment b with color c ( 0 < a<=b <= N, 0 < c <= 30).

  2. Q a b
    a and b are integers. This is a query operation. It means that someone asked that how many kinds of colors were there from segment a to segment b ( 0 < a<=b <= N).

Please note that the operations are given in time sequence.

The input ends with M = 0 and N = 0.

Output
For each query operation, print all kinds of color on the queried segments. For color 1, print 1, for color 2, print 2 … etc. And this color sequence must be in ascending order.

Sample Input

5 10
P 1 2 3
P 2 3 4
Q 2 3
Q 1 3
P 3 5 4
P 1 2 7
Q 1 3
Q 3 4
P 5 5 8
Q 1 5
0 0

Sample Output

4
3 4
4 7
4
4 7 8

Source
2014 ACM/ICPC Asia Regional Guangzhou Online


一开始看到统计区间不同颜色数量;
想到了莫队;
可又带修改操作;
-----> 线段树
用二进制表示每一位的颜色选取情况即可;

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<set>
#include<vector>
#include<queue>
#include<bitset>
#include<ctime>
#include<deque>
#include<stack>
#include<functional>
#include<sstream>
#include<cctype>
//#pragma GCC optimize("O3")
using namespace std;
#define maxn 1000005
#define inf 0x3f3f3f3f
#define INF 0x7fffffff
#define rdint(x) scanf("%d",&x)
#define rdllt(x) scanf("%lld",&x)
typedef long long  ll;
typedef unsigned long long ull;
typedef unsigned int U;
#define ms(x) memset((x),0,sizeof(x))
const int mod = 10000007;
#define Mod 20100403
#define sq(x) (x)*(x)
#define eps 1e-10
const int N = 1505;

inline int rd() {
	int x = 0;
	char c = getchar();
	bool f = false;
	while (!isdigit(c)) {
		if (c == '-') f = true;
		c = getchar();
	}
	while (isdigit(c)) {
		x = (x << 1) + (x << 3) + (c ^ 48);
		c = getchar();
	}
	return f ? -x : x;
}

ll gcd(ll a, ll b) {
	return b == 0 ? a : gcd(b, a%b);
}
ll sqr(ll x) { return x * x; }

int n, m;
struct node {
	int l, r;
	int lazy;
	int sum;
}tree[maxn<<2];

void pushup(int rt) {
	tree[rt].sum = tree[rt << 1].sum | tree[rt << 1 | 1].sum;
}

void pushdown(int rt) {
	if (tree[rt].lazy) {
		tree[rt << 1].lazy = tree[rt].lazy;
		tree[rt << 1 | 1].lazy = tree[rt].lazy;
		tree[rt << 1].sum = tree[rt].lazy;
		tree[rt << 1 | 1].sum = tree[rt].lazy;
		tree[rt].lazy = 0;
	}
}

void build(int l, int r, int rt) {
	tree[rt].lazy = 0;
	if (l == r) {
		tree[rt].sum = 2; return;
	}
	int mid = (l + r) >> 1;
	build(l, mid, rt << 1); build(mid + 1, r, rt << 1 | 1);
	pushup(rt);
}

void update(int col, int L, int R, int l, int r, int rt) {
	if (L <= l && r <= R) {
		tree[rt].lazy = 1 << (col - 1);
		tree[rt].sum = 1 << (col - 1); return;
	}
	pushdown(rt);
	int mid = (l + r) >> 1;
	if (L <= mid)update(col, L, R, l, mid, rt << 1);
	if (mid < R)update(col, L, R, mid + 1, r, rt << 1 | 1);
	pushup(rt);
}

int query(int L, int R, int l, int r, int rt) {
	if (L <= l && r <= R) {
		return tree[rt].sum;
	}
	pushdown(rt);
	int mid = (l + r) >> 1;
	int ans = 0;
	if (L <= mid)ans |= query(L, R, l, mid, rt << 1);
	if (mid < R)ans |= query(L, R, mid + 1, r, rt << 1 | 1);
	return ans;
}

int main()
{
	//ios::sync_with_stdio(false);
	while (cin >> n >> m&&n&&m) {
		build(1, n, 1);
		while (m--) {
			char ch[3];
			cin >> ch;
			if (ch[0] == 'P') {
				int a, b, c; rdint(a); rdint(b); rdint(c);
				update(c, a, b, 1, n, 1);
			}
			else {
				int a, b; rdint(a); rdint(b);
				int ans = query(a, b, 1, n, 1);
				int tot = 0;
				for (int i = 1; i <= 30; i++) {
					if (ans&(1 << (i-1))) {
						if (!tot)cout << i;
						else cout << ' ' << i;
						tot++;
					}
				}
				cout << endl;
			}
		}
	}

}

猜你喜欢

转载自blog.csdn.net/qq_40273481/article/details/82928312