并查集C - More is better

Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex,   the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
  Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.  
  Sample Input
 
    
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
  Sample Output
4
2
这样时间超限;
#include<stdio.h>
#define N 10000000
int pre[N],num[N];
int find(int x) /*寻找根节点*/
{
    while(pre[x]!=x)
        x=pre[x];
    return x;
}
void merge(int a,int b)/*合并a和b*/
{
    int p=find(a);
    int q=find(b);
    if(p!=q)
    {
        pre[p]=q;
        num[q]=num[q]+num[p];/*合并集合中元素个数*/
    }
}
int main()
{
    int n,a,b,i,sum,max;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
        {
            printf("1\n");
            continue;
        }
        max=0;
        for(int i=0;i<=N;i++)
        {
            pre[i]=i;
        num[i]=1;/*开始时数量都为1,根节点为自己*/
        }
        for(i=0; i<n; i++)
        {
            scanf("%d%d",&a,&b);
            if(a>max)
                max=a;
            if(b>max)
                max=b;
            merge(a,b); /*合并集合*/
        }
        int Max=0;
        for(i=1; i<=max; i++)
            if(num[i]>Max) /*查找最大值*/
                Max=num[i];
        printf("%d\n",Max);
    }
    return 0;
}
过了的代码:
#include<stdio.h>
int m,rank[10000010],pre[10000010],max;
void make()
{
    int i;
    for(i=0; i<10000010; i++)
    {
        pre[i]=i;
        rank[i]=1;
    }
}
int find(int x)
{
    if(pre[x]!=x)
        x=pre[x];
    return x;
}
void merge(int x,int y)
{
    pre[x]=y;
    rank[y]+=rank[x];
    max=max>rank[y]?max:rank[y];
    rank[x]=0;
}
int main()
{
    int x,y,i;
    while(scanf("%d",&m)!=EOF)
    {
        make();
        max=0;
        for(i=0; i<m; i++)
        {
            scanf("%d%d",&x,&y);
            x=find(x);
            y=find(y);
            if(x!=y)
                merge(x,y);
        }
        if(max)
            printf("%d\n",max);
        else
            printf("1\n");
    }
}
 


猜你喜欢

转载自blog.csdn.net/u013514659/article/details/19929713
今日推荐