HDU-1856 More is better(并查集)

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 29576    Accepted Submission(s): 10510


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 

Sample Input
 
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
 
 
4 2

题意:王老师选择男孩,尽量选最多的人数,最少选一个,而且选的男孩只能直接或者间接是朋友。

思路:

1.当 n = 1 时,输出 1

2.当 n = 2 时,输出 2

3.当 n > 2 时,用并查集,求的不是有多少个集合,而是每个集合中的人数


代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#define N 10000010
using namespace std;
int pre[N],c[N];
int find(int x)
{ 
    if(pre[x]!=x)
        pre[x]=find(pre[x]);
    int r = pre[x] ;
    int i = x , j ;
    while( i != r )
    {
         j = pre[ i ];
         pre[ i ] = r ;
         i = j;
    }
    return r ;
}

void join(int x,int y)
{
    int fx = find(x), fy = find(y);
    if(fx != fy)
    {
        pre[fx] = fy;
        c[fy]+=c[fx];     //合并两个集合的人数
    }     
}
int main(void)
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)
        {
            printf("1\n");
            continue;
        }
        if(n==1)
        {
            printf("2\n");
            continue;
        }
        int a,b,maxa=0;
        for(int i=1;i<N;i++)
        {
            pre[i]=i;c[i]=1;
        }
        for(int k=1;k<=n;k++)
        {
            scanf("%d %d",&a,&b);
            join(a,b);
            maxa=max(maxa,a);maxa=max(maxa,b);
        }

        int maxn=0;
        for(int i=1;i<=maxa;i++)
        {
            if(c[i]>maxn)maxn=c[i];
        }
        printf("%d\n",maxn);
    }
}




猜你喜欢

转载自blog.csdn.net/theendbigins/article/details/77404729
今日推荐