并查集——More is better (HDU - 1856)

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output

4
2
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
using namespace std;
const int maxn = 1e7+5;
int fa[maxn],sum[maxn]; // sum用来存储该集合中的元素个数

int findfa(int x)
{
    return fa[x] == x?x:fa[x] = findfa(fa[x]);
}
void Union(int a,int b)
{
    int x = findfa(a),y = findfa(b);
    if(x != y)
    {
        fa[x] = y;
        sum[y] += sum[x]; //全部加到父节点上
    }
}
int main()
{
    int n;
    while(scanf("%d",&n) != EOF)
    {
        if(!n)
        {
            cout<<"1"<<endl;
            continue;
        }
        for(int i = 1; i <= maxn; i++)
        {
              fa[i] = i;
              sum[i] = 1;
        }
        int a,b,temp = 0;
        for(int i = 0; i < n; i++)
        {
            scanf("%d %d",&a,&b);
            temp = max(temp,a);
            temp = max(temp,b);
            Union(a,b);
        }
        int cnt = 0;
        for(int i = 1; i <= temp; i++)
            cnt = max(cnt,sum[i]);
        cout<<cnt<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Nothing_227/article/details/88951704