【笨方法学PAT】1054 The Dominant Color (20 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/83305281

一、题目

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2​24​​). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

二、题目大意

给出一个n*m的数字矩阵,求其中超过半数的出现次数最多的数字

三、考点

数组

四、注意

1、可以使用一个数组保存所有数字出现的次数;

2、可以一边读取,一遍判断。

五、代码

#include<iostream>
#define N 100000001
using namespace std;
int a[N] = {0};
int main() {
	//read
	int m, n;
	cin >> m >> n;
	bool flag = false;
	for (int i = 0; i < n; ++i) {
		for (int j = 0; j < m; ++j) {
			int t;
			cin >> t;
			a[t]++;
			if (a[t] > m*n/2) {
				cout << t;
				flag = true;
				break;
			}
		}
		if (flag == true)
			break;
	}

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/83305281