A1054 The Dominant Color (20 分)

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2​24​​). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

题意:

给出 M 列 N 行的数字矩阵,求其中超过半数的出现次数最多的数字

输入:M (≤800) and N (≤600)

思路:

首先想到的是采用数组存储,进行计数即可。但是忽略了一点,给出的数据很可能很大,导致内存超限

因此采用 map ,建立 map<int, int> ,作为数字与其出现次数的映射关系

知识点:

map

  1. find(key) 返回键为 key 的映射的迭代器
  2. map 的访问有两种方式:下标和迭代器。迭代器访问的定义方式为: map<typename1, typename2>::iterator it; 其中,采用 it->first 访问键,采用 it->second 访问值
#include <cstdio>
#include <map>
using namespace std;
int main(){
  int n, m, num;
  scanf("%d%d", &n, &m);
  map<int, int> count;
  for(int i = 0; i < n; i++){
    for(int j = 0; j < m; j++){
      scanf("%d", &num);
      if(count.find(num) != count.end())
        count[num]++;
      else
        count[num] = 1;
    }
  }
  int k, max = 0;
  for(map<int, int>::iterator it = count.begin(); it != count.end(); it++){
    if(it->second > max){
      k = it->first;
      max = it->second;
    }
  }
  printf("%d\n", k);
  return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_35093872/article/details/87699082