PAT 1054 The Dominant Color (20分)

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2​24​​). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24
题意:就是找出像素矩阵中出现次数最多的点, (水题)
map记录每个像素出现的位置,然后取最大值就好,注意矩阵最大有 800 * 600 == 48万个数据,因此需要用scanf去输入矩阵中的每个元素
#include<cstdio>
#include<map>
using namespace std;

map<int,int> hashc;
int main(){
    int n,m,num,max_cnt = 0,max_num;;
    scanf("%d%d",&n,&m);

    for (int i  = 0; i < n; ++i)
        for (int j = 0; j < m; ++j){
            scanf("%d",&num);
            hashc[num]++;
            if (hashc[num] > max_cnt){
                max_cnt = hashc[num];
                max_num = num;
            }
        }

    printf("%d",max_num);

    return 0;
}
发布了423 篇原创文章 · 获赞 38 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/weixin_41514525/article/details/104966069