3117图的基本存储的基本方式二

版权声明:本文为博主胡乱瞎写,如有需要,随便转载,顺带给个momo哒。 https://blog.csdn.net/rangran/article/details/81872306

图的基本存储的基本方式二

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

解决图论问题,首先就要思考用什么样的方式存储图。但是小鑫却怎么也弄不明白如何存图才能有利于解决问题。你能帮他解决这个问题么?

Input

 多组输入,到文件结尾。

每一组第一行有两个数n、m表示n个点,m条有向边。接下来有m行,每行两个数u、v代表u到v有一条有向边。第m+2行有一个数q代表询问次数,接下来q行每行有一个询问,输入两个数为a,b。

注意:点的编号为0~n-1,2<=n<=500000 ,0<=m<=500000,0<=q<=500000,a!=b,输入保证没有自环和重边

Output

 对于每一条询问,输出一行。若a到b可以直接连通输出Yes,否则输出No。

Sample Input

2 1
0 1
2
0 1
1 0

Sample Output

Yes
No

Hint

 

Source

lin


#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct node
{
    int data;
    struct node *next;
};
int main()
{
    int m,n,u,v;
    struct node *p,*q,*a[500050];
    while(~scanf("%d %d",&n,&m))
    {
        int i;
        for(i=0; i<n; i++)
            a[i]=NULL;
        while(m--)
        {
            scanf("%d %d",&u,&v);
            if(a[u]==NULL)
            {
                p=(struct node *)malloc(sizeof(struct node));
                p->data=v;
                p->next=NULL;
                a[u]=p;
            }
            else
            {
                p=(struct node *)malloc(sizeof(struct node));
                p->data=v;
                p->next=a[u]->next;
                a[u]->next=p;
            }
        }
        int t;
        scanf("%d",&t);
        while(t--)
        {
            int f=0;
            scanf("%d %d",&u,&v);
            q=a[u];
            while(q!=NULL)
            {
                if(q->data==v)
                {
                    f=1;
                    break;
                }
                q=q->next;
            }
            if(f==1)printf("Yes\n");
            else printf("No\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/rangran/article/details/81872306