图的基本存储的基本方式二

图的基本存储的基本方式二
Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
解决图论问题,首先就要思考用什么样的方式存储图。但是小鑫却怎么也弄不明白如何存图才能有利于解决问题。你能帮他解决这个问题么?

Input
多组输入,到文件结尾。
每一组第一行有两个数n、m表示n个点,m条有向边。接下来有m行,每行两个数u、v代表u到v有一条有向边。第m+2行有一个数q代表询问次数,接下来q行每行有一个询问,输入两个数为a,b。

注意:点的编号为0~n-1,2<=n<=500000 ,0<=m<=500000,0<=q<=500000,a!=b,输入保证没有自环和重边

Output
对于每一条询问,输出一行。若a到b可以直接连通输出Yes,否则输出No。
Sample Input
2 1
0 1
2
0 1
1 0
Sample Output
Yes
No
Hint

Source
lin

#include <stdio.h>
#include <stdlib.h>

struct node
{
    int date;
    struct node *next;
};
int main()
{
    int i,n,m,u,v,a,b,q,flag;
    struct node *head[500005],*p,*s; //每个节点都要建立一条单链表,故为头结点开数组
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(i=0; i<n; i++)
            head[i]=NULL; //初始化
        while(m--)
        {
            scanf("%d%d",&u,&v);
            if(head[u]==NULL) //建立头结点
            {
                head[u]=(struct node*)malloc(sizeof(struct node));
                head[u]->date=v;
                head[u]->next=NULL;
            }
            else //插入新节点
            {
                s=head[u]->next;
                p=(struct node*)malloc(sizeof(struct node));
                p->date=v;
                p->next=s;
                head[u]->next=p;
            }
        }
        scanf("%d",&q);
        while(q--)
        {
            flag=0;
            scanf("%d%d",&a,&b);
            if(head[a]==NULL)
                printf("No\n");
            else
            {
                s=head[a];
                while(s)
                {
                    if(s->date==b)
                    {
                        flag=1;
                        break;
                    }
                    else
                        s=s->next;
                }
                if(flag)
                    printf("Yes\n");
                else
                    printf("No\n");
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Dmenghu/article/details/81660708