UVA11300 Spreading the Wealth【水题】

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.
Input
There is a number of inputs. Each input begins with n (n < 1000001), the number of people in the village. n lines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.
Output
For each input, output the minimum number of coins that must be transferred on a single line.
Sample Input
3
100
100
100
4
1
2
5
4
Sample Output
0
4

问题链接UVA11300 Spreading the Wealth
问题描述:(略)
问题分析
    这是蓝书的一道思维题,参见蓝书第一章,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C语言程序如下:

/* UVA11300 Spreading the Wealth */

#include <bits/stdc++.h>

using namespace std;

const int N = 1e6;
long long a[N + 1], c[N + 1], tot, m;

int main()
{
    int n;
    while(scanf("%d", &n) == 1) {
        tot = 0;
        for(int i = 1; i <= n; i++) {
            scanf("%lld", &a[i]);
            tot += a[i];
        }

        m = tot / n;
        c[0] = 0;
        for(int i = 1; i < n; i++) c[i] = c[i - 1] + a[i] - m;
        sort(c, c + n);
        long long x1 = c[n / 2], ans = 0;
        for(int i = 0; i < n; i++) ans += abs(x1 - c[i]);

        printf("%lld\n", ans);
    }

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/tigerisland45/p/10159928.html
今日推荐