Asteroids

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/SSLGZ_yyc/article/details/85016024

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

  • Line 1: Two integers N and K, separated by a single space.
  • Lines 2…K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

  • Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where “X” is an asteroid and “.” is empty space:
X.X
.X.
.X.

OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
题目在意如下:
题目给出一个矩阵,上面有敌人,每个子弹可以打出一横行或者一竖行,问最少用多少子弹消灭都有敌人,如:
X.X
.X.
.X.
x表示敌人,显然用两个子弹就可以解决所有敌人。

.
.
.
.
.
分析
建图:二分图的X部为每一行,Y部为每一列,如果(i,j)有一个敌人,那么连接X部的i与Y部的j。
该二分图的最大匹配数则是最少要打的枪数。
.
.
.
.
.
程序:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int ans,tj,n,m,link[4000],v[4000],head[4000];

struct node
{
	int to,next;
}f[4000];

int find(int x)
{
	for (int i=head[x];i;i=f[i].next)
	{
		int j=f[i].to;
		if (!v[j])
		{
			int q=link[j];
		    link[j]=x;
		    v[j]=1;
		    if (!q||find(q)) return 1;
		    link[j]=q;
		}
		
	}
	return 0;
}

int main()
{
	scanf("%d%d",&n,&m);
	for (int i=1;i<=m;i++)
	{
		int x,y;
		scanf("%d%d",&x,&y);
		
		f[++tj].next=head[x];
		f[tj].to=y;
		head[x]=tj;
	}
	for (int i=1;i<=n;i++)
	{
		memset(v,0,sizeof(v));
		ans+=find(i);
	}
	printf("%d",ans);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SSLGZ_yyc/article/details/85016024
今日推荐