HDU1240 Asteroids!/POJ 2225 Asteroids!(三维BFS+优先队列)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_42391248/article/details/82986070

Asteroids!

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3435   Accepted: 1285

Description

You're in space.
You want to get home.
There are asteroids.
You don't want to hit them.

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:

  1. Start line - A single line, "START N", where 1 <= N <= 10.
  2. Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:
    • 'O' - (the letter "oh") Empty space
      'X' - (upper-case) Asteroid present
  3. Starting Position - A single line, "A B C", denoting the [A,B,C] coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.
  4. Target Position - A single line, "D E F", denoting the [D,E,F] coordinates of your target's position. The coordinate values will be integers separated by individual spaces.
  5. End line - A single line, "END"


The origin of the coordinate system is [0,0,0]. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.
The second coordinate in a set indicates the row. Top row = 0.
The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.
 

Output

For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.

Sample Input

START 1
O
0 0 0
0 0 0
END
START 3
XXX
XXX
XXX
OOO
OOO
OOO
XXX
XXX
XXX
0 0 1
2 2 1
END
START 5
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
XXXXX
XXXXX
XXXXX
XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END

Sample Output

1 0
3 4
NO ROUTE

题目大意:START后面的数字表示N,给出N行N列N层的正方体,接下来是起始坐标和终点坐标,分别表示列,行,层(这里和我们常规思维的坐标顺序不一样)END结束。

X表示墙,O表示空地,问从起始到终点最少多少步。

这一题没什么东西,就是简单的三维bfs。

具体代码如下:

#include<iostream>
#include<queue>
#include<cstring>
#include<string>
using namespace std;
char map[10][10][10];
int d[6][3]={0,1,0,0,-1,0,1,0,0,-1,0,0,0,0,1,0,0,-1};
int vis[10][10][10];
struct node{
	int x,y,z,step;
	friend bool operator <(node a,node b)
    {
        return a.step>b.step;
    }
};
int n;
node a,b;
int check1(node now)
{
	if(now.x==b.x&&now.y==b.y&&now.z==b.z)
		return 1;
	return 0;
}
int check2(int x,int y,int z)
{
	if(x<0||y<0||z<0||x>=n||y>=n||z>=n)
		return 1;
	return 0;
}
int BFS()
{
	memset(vis,0,sizeof(vis));
	node now,next;
	now=a;
	priority_queue<node> q;
	q.push(now);
	while(!q.empty())
	{
		now=q.top();
		q.pop();
		if(check1(now))
			return now.step;
		for(int i=0;i<6;i++)
		{
			int nx=now.x+d[i][0];
			int ny=now.y+d[i][1];
			int nz=now.z+d[i][2];
			if(check2(nx,ny,nz)) continue;
			if(map[nz][ny][nx]=='X') continue;
			if(vis[nz][ny][nx]) continue;
			vis[nz][ny][nx]=1;
			next.step=now.step+1;
			next.x=nx;
			next.y=ny;
			next.z=nz;
			q.push(next);
		}
	}
	return -1;
}
int main()
{
	string s;
	while(cin>>s)
	{
		cin>>n;
		memset(map,'O',sizeof(map));
		for(int i=0;i<n;i++)
			for(int j=0;j<n;j++)
				cin>>map[i][j];	
		cin>>a.x>>a.y>>a.z>>b.x>>b.y>>b.z;
		cin>>s;
		a.step=0;
		int ans=BFS();							
		if(ans!=-1)
			cout<<n<<" "<<ans<<endl;
		else
			cout<<"NO ROUTE"<<endl;			
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42391248/article/details/82986070
今日推荐