【洛谷P3469】[POI2008]LO-Blockade 解题报告

P3469[POI2008]LO-Blockade

题意翻译

在Byteotia有n个城镇。 一些城镇之间由无向边连接。 在城镇外没有十字路口,尽管可能有桥,隧道或者高架公路(反正不考虑这些)。每两个城镇之间至多只有一条直接连接的道路。人们可以从任意一个城镇直接或间接到达另一个城镇。 每个城镇都有一个公民,他们被孤独所困扰。事实证明,每个公民都想拜访其他所有公民一次(在主人所在的城镇)。所以,一共会有n*(n-1)次拜访。

不幸的是,一个程序员总罢工正在进行中,那些程序员迫切要求购买某个软件。

作为抗议行动,程序员们计划封锁一些城镇,阻止人们进入,离开或者路过那里。

正如我们所说,他们正在讨论选择哪些城镇会导致最严重的后果。

编写一个程序:

读入Byteotia的道路系统,对于每个被决定的城镇,如果它被封锁,有多少访问不会发生,输出结果。

输入输出格式

第一行读入n,m,分别是城镇数目和道路数目

城镇编号1~n

接下来m行每行两个数字a,b,表示a和b之间有有一条无向边

输出n行,每行一个数字,为第i个城镇被锁时不能发生的访问的数量。

题目描述

There are exactly nn towns in Byteotia.

Some towns are connected by bidirectional roads.

There are no crossroads outside towns, though there may be bridges, tunnels and flyovers. Each pair of towns may be connected by at most one direct road. One can get from any town to any other-directly or indirectly.

Each town has exactly one citizen.

For that reason the citizens suffer from loneliness.

It turns out that each citizen would like to pay a visit to every other citizen (in his host's hometown), and do it exactly once. So exactly n\cdot (n-1)n⋅(n−1) visits should take place.

That's right, should.

Unfortunately, a general strike of programmers, who demand an emergency purchase of software, is under way.

As an act of protest, the programmers plan to block one town of Byteotia, preventing entering it, leaving it, and even passing through.

As we speak, they are debating which town to choose so that the consequences are most severe.

Task Write a programme that:

reads the Byteotian road system's description from the standard input, for each town determines, how many visits could take place if this town were not blocked by programmers, writes out the outcome to the standard output.

给定一张无向图,求每个点被封锁之后有多少个有序点对(x,y)(x!=y,1<=x,y<=n)满足x无法到达y

输入输出格式

输入格式:

In the first line of the standard input there are two positive integers: \(n\) and \(m\) (\(1\le n\le 100000, 1\le m\le 500000\) )denoting the number of towns and roads, respectively.

The towns are numbered from 1 to \(n\).

The following mm lines contain descriptions of the roads.

Each line contains two integers \(a\) and \(b\) (\(1\le a<b\le n\)) and denotes a direct road between towns numbered \(a\) and \(b\).

输出格式:

Your programme should write out exactly nn integers to the standard output, one number per line. The i^{th}ithline should contain the number of visits that could not take place if the programmers blocked the town no. \(i\)

输入输出样例

输入样例#1:

5 5
1 2
2 3
1 3
3 4
4 5

输出样例#1:

8
8
16
14
8

算法

Tarjan找割点

思路

I.设在搜索树T中以x为根的树包含的点集为SubTree(x)。

II.这里去除割点可以理解为删除与该点相连的所有边。

III.这里提到的连通块是指当某一割点去除时:1.其中任何两个点都能相互到达 2.没有更大的连通块包含该块 当然,根据II,我们把单独的X也看做一个连通块

IV.为了方便,我们直接将(x,y)(满足x不能到y)成为“点对”

V. ~S:S的补集,A^B:在A中不包括点B的所有点构成的集合

利用Tarjan查找割点的同时,我们可以找出该割点X去除后剩余的连通块(有两种情况,一种是在SubTree(X)^X中,另一种是~SubTree(X))。

只要能够理解割点的求解过程,这还是很好理解的,这里不再赘述。

然后要求“点对”。

对于一个点X,不管是否为割点,点对(i,j)为“点对”,当且仅当

i != j且i、j属于两个不同的连通块

根据定义,很容易证明这个推论。

代码有多种写法,这里选取我能想到的最简单的写法。

在枚举连通块时,ans加上s[to[i]] * ( n - s[to[i]] ),即一次性处理一个连通块的所有点,它们与其他不属于这个连通块的点都构成“点对”。当然,别忘了X与~SubTree(X)。

代码

#include<bits/stdc++.h>
using namespace std;
#define LL long long
#define MAXN 100005
#define MAXM 1000005

int n, m;
int hd[MAXN], nxt[MAXM], to[MAXM], tot;
int dfn[MAXN], low[MAXN], root, num;
LL ans[MAXN];
int s[MAXN];

void Add( int x, int y ){ nxt[++tot] = hd[x]; hd[x] = tot; to[tot] = y; }

void DFS( int x ){
    s[x] = 1;
    low[x] = dfn[x] = ++num;
    LL b(0);
    for ( int i = hd[x]; i; i = nxt[i] ){
        if ( !dfn[to[i]] ){
            DFS( to[i] ); s[x] += s[to[i]];
            low[x] = min( low[x], low[to[i]] );
            if ( dfn[x] <= low[to[i]] ) ans[x] += (long long)s[to[i]] * ( n - s[to[i]] ), b += s[to[i]];//发现新的连通块!
        } else low[x] = min( low[x], dfn[to[i]] );
    }
    ans[x] += (long long)( n - b - 1 ) * ( b + 1 ) + ( n - 1 );//算上~SubTree(X)与X
}

int main(){
    scanf( "%d%d", &n, &m );
    for ( int i = 1; i <= m; ++i ){
        int x, y; scanf( "%d%d", &x, &y ); Add( x, y ); Add( y, x );
    }
    DFS( 1 );
    for ( int i = 1; i <= n; ++i ) printf( "%lld\n", ans[i] );
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/louhancheng/p/10122026.html