【洛谷】3469:[POI2008]BLO-Blockade【割点统计size】

P3469 [POI2008]BLO-Blockade

题意翻译

在Byteotia有n个城镇。 一些城镇之间由无向边连接。 在城镇外没有十字路口,尽管可能有桥,隧道或者高架公路(反正不考虑这些)。每两个城镇之间至多只有一条直接连接的道路。人们可以从任意一个城镇直接或间接到达另一个城镇。 每个城镇都有一个公民,他们被孤独所困扰。事实证明,每个公民都想拜访其他所有公民一次(在主人所在的城镇)。所以,一共会有n*(n-1)次拜访。

不幸的是,一个程序员总罢工正在进行中,那些程序员迫切要求购买某个软件。

作为抗议行动,程序员们计划封锁一些城镇,阻止人们进入,离开或者路过那里。

正如我们所说,他们正在讨论选择哪些城镇会导致最严重的后果。

编写一个程序:

读入Byteotia的道路系统,对于每个被决定的城镇,如果它被封锁,有多少访问不会发生,输出结果。

输入输出格式

第一行读入n,m,分别是城镇数目和道路数目

城镇编号1~n

接下来m行每行两个数字a,b,表示a和b之间有有一条无向边

输出n行,每行一个数字,为第i个城镇被锁时不能发生的访问的数量。



@[chen_zhe](/space/show?uid=8457)

翻译提供者:Park

题目描述

There are exactly nn towns in Byteotia.

扫描二维码关注公众号,回复: 3686318 查看本文章

Some towns are connected by bidirectional roads.

There are no crossroads outside towns, though there may be bridges, tunnels and flyovers. Each pair of towns may be connected by at most one direct road. One can get from any town to any other-directly or indirectly.

Each town has exactly one citizen.

For that reason the citizens suffer from loneliness.

It turns out that each citizen would like to pay a visit to every other citizen (in his host's hometown), and do it exactly once. So exactly n\cdot (n-1)n(n1) visits should take place.

That's right, should.

Unfortunately, a general strike of programmers, who demand an emergency purchase of software, is under way.

As an act of protest, the programmers plan to block one town of Byteotia, preventing entering it, leaving it, and even passing through.

As we speak, they are debating which town to choose so that the consequences are most severe.

Task Write a programme that:

reads the Byteotian road system's description from the standard input, for each town determines, how many visits could take place if this town were not blocked by programmers, writes out the outcome to the standard output.

给定一张无向图,求每个点被封锁之后有多少个有序点对(x,y)(x!=y,1<=x,y<=n)满足x无法到达y

输入输出格式

输入格式:

 

In the first line of the standard input there are two positive integers: nn and mm (1\le n\le 100\ 0001n100 000, 1\le m\le 500\ 0001m500 000) denoting the number of towns and roads, respectively.

The towns are numbered from 1 to nn.

The following mm lines contain descriptions of the roads.

Each line contains two integers aa and bb (1\le a<b\le n1a<bn) and denotes a direct road between towns numbered aaand bb.

 

输出格式:

 

Your programme should write out exactly nn integers to the standard output, one number per line. The i^{th}ith line should contain the number of visits that could not take place if the programmers blocked the town no. ii.

输入输出样例

输入样例#1:  复制
5 5
1 2
2 3
1 3
3 4
4 5
输出样例#1:  复制
8
8
16
14
8

Solution

不是割点的点所产生的贡献肯定是$2*(n-1)$,如果是割点,那么就是像统计子树一样要统计出这个点能到达的点和能到达它的点的数量,进行乘法原理计算方案数。

在$tarjan$的过程中可以像走树一样,把能到达的点当成子树统计size,每次加上这个子树的size乘上之前走过的子树的size即可,最后再把内外的点对数的贡献加上即可。

Code

#include<bits/stdc++.h>
#define LL long long
using namespace std;

int n, m;

struct Node {
    int u, v, nex;
    Node(){ }
    Node(int u, int v, int nex) :
        u(u), v(v), nex(nex) { }
} Edge[1000005];

int h[100005], stot = 1;
void add(int u, int v) {
    Edge[++stot] = Node(u, v, h[u]);
    h[u] = stot;
}

LL ans[100005];
int dfn[100005], low[100005], idc, siz[100005];
void tarjan(int u) {
    dfn[u] = low[u] = ++ idc;
    int tot = 0;
    siz[u] = 1;
    for(int i = h[u]; i; i = Edge[i].nex) {
        int v = Edge[i].v;
        if(!dfn[v]) {
            tarjan(v);
            siz[u] += siz[v];
            low[u] = min(low[u], low[v]);
            if(low[v] >= dfn[u]) {
                ans[u] += 1ll * tot * siz[v];
                tot += siz[v]; 
            }
        } else low[u] = min(low[u], dfn[v]);
    }
    ans[u] += 1ll * tot * (n - tot - 1);
}

int main() {
    scanf("%d%d", &n, &m);
    for(int i = 1; i <= m; i ++) {
        int u, v;
        scanf("%d%d", &u, &v);
        add(u, v);    add(v, u);
    }
    tarjan(1);
    for(int i = 1; i <= n; i ++)
        printf("%lld\n", (ans[i] + n - 1) << 1);
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/wans-caesar-02111007/p/9833271.html