洛谷 P3469 [POI2008]BLO-Blockade(割点) 题解

题目来源:

https://www.luogu.org/problemnew/show/P3469

题目描述:

 

题意翻译

在Byteotia有n个城镇。 一些城镇之间由无向边连接。 在城镇外没有十字路口,尽管可能有桥,隧道或者高架公路(反正不考虑这些)。每两个城镇之间至多只有一条直接连接的道路。人们可以从任意一个城镇直接或间接到达另一个城镇。 每个城镇都有一个公民,他们被孤独所困扰。事实证明,每个公民都想拜访其他所有公民一次(在主人所在的城镇)。所以,一共会有n*(n-1)次拜访。

不幸的是,一个程序员总罢工正在进行中,那些程序员迫切要求购买某个软件。

作为抗议行动,程序员们计划封锁一些城镇,阻止人们进入,离开或者路过那里。

正如我们所说,他们正在讨论选择哪些城镇会导致最严重的后果。

编写一个程序:

读入Byteotia的道路系统,对于每个被决定的城镇,如果它被封锁,有多少访问不会发生,输出结果。

输入输出格式

第一行读入n,m,分别是城镇数目和道路数目

城镇编号1~n

接下来m行每行两个数字a,b,表示a和b之间有有一条无向边

输出n行,每行一个数字,为第i个城镇被锁时不能发生的访问的数量。



@[chen_zhe](/space/show?uid=8457)

翻译提供者:Park

题目描述

There are exactly nn towns in Byteotia.

Some towns are connected by bidirectional roads.

There are no crossroads outside towns, though there may be bridges, tunnels and flyovers. Each pair of towns may be connected by at most one direct road. One can get from any town to any other-directly or indirectly.

Each town has exactly one citizen.

For that reason the citizens suffer from loneliness.

It turns out that each citizen would like to pay a visit to every other citizen (in his host's hometown), and do it exactly once. So exactly n\cdot (n-1)n⋅(n−1) visits should take place.

That's right, should.

Unfortunately, a general strike of programmers, who demand an emergency purchase of software, is under way.

As an act of protest, the programmers plan to block one town of Byteotia, preventing entering it, leaving it, and even passing through.

As we speak, they are debating which town to choose so that the consequences are most severe.

Task Write a programme that:

reads the Byteotian road system's description from the standard input, for each town determines, how many visits could take place if this town were not blocked by programmers, writes out the outcome to the standard output.

给定一张无向图,求每个点被封锁之后有多少个有序点对(x,y)(x!=y,1<=x,y<=n)满足x无法到达y

输入输出格式

输入格式:

In the first line of the standard input there are two positive integers: nn and mm ( 1\le n\le 100\ 0001≤n≤100 000 , 1\le m\le 500\ 0001≤m≤500 000 ) denoting the number of towns and roads, respectively.

The towns are numbered from 1 to nn .

The following mm lines contain descriptions of the roads.

Each line contains two integers aa and bb ( 1\le a<b\le n1≤a<b≤n ) and denotes a direct road between towns numbered aaand bb .

输出格式:

Your programme should write out exactly nn integers to the standard output, one number per line. The i^{th}ith line should contain the number of visits that could not take place if the programmers blocked the town no. ii .

输入输出样例

输入样例#1: 复制

5 5
1 2
2 3
1 3
3 4
4 5

输出样例#1: 复制

8
8
16
14
8

解题思路:

      poi的题目。。刚学完割点,感觉就是用割点做,把取掉的点分为两类,对于不是割点的点,那么删掉之后只是会影响这点到别的点和别的点到这个点,加起来就是2*(n-1)个点对,对于是割点的点就是本身的2*(n-1)个点加上去掉这个点后形成所有新的连通块的大小之积就行了,但是好菜的我,一开始不懂怎样记录连通块大小,看了大佬的博客,终于懂了。。。

如果cur是割点,计tot为目前已访问到的联通块中的节点总数,这样每找到一个联通块,ans值应+tot*2*num[x],其中num[x]是x所在的联通块的节点个数。

判断cur是否为割点的条件,同样是判断去除节点cur后,其dfs子树是否是一新的联通块的条件。

要注意计算完子树,后还有节点cur的父节点所在的联通块,其节点个数为n-tot。ans值要在最后加上(n-tot)*tot*2。

记上一题相似的题目   POJ 2117 Electricity,一定要记得做,加深理解。。

代码:

#include <iostream>
#include <string>
#include <cstring>
#include <vector>
#include <queue>
#include <stack>
#include <algorithm>
#include <cmath>
#include <cctype>
#include <iomanip>
#define ll long long
const int Maxn=1000005;
using namespace std;
int dfn[Maxn],low[Maxn];
ll size[Maxn],ans[Maxn];
int n,m,tot;
vector<int>E[Maxn];
void tarjan(int u)
{
	dfn[u]=low[u]=++tot;
	size[u]=1;
	ll sum=0;
	for(int i=0;i<E[u].size();i++)
	{
		int v=E[u][i];
		if(!dfn[v]){
			tarjan(v);
			low[u]=min(low[u],low[v]);
			size[u]+=size[v];
			if(low[v]>=dfn[u]){
				ans[u]+=sum*size[v];
				sum+=size[v];
			}
		}
		else low[u]=min(low[u],dfn[v]);
		//cout<<u<<" "<<ans[u]<<size[u]<<endl;
	}
	ans[u]+=sum*(n-sum-1);
}
int main()
{
	std::ios::sync_with_stdio(false);	
	cin>>n>>m;
	tot=0;
	for(int i=1;i<=m;i++)
	{
		int a,b;
		cin>>a>>b;
		E[a].push_back(b);
		E[b].push_back(a);
	}
	tarjan(1);
//	for(int i=1;i<=n;i++)
//	cout<<(ans[i]+n-1)*2<<endl;
	for(int i=1;i<=n;i++)
	cout<<size[i]<<" ";



	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40400202/article/details/81198060