Atcoder Beginner Contest 115 D - Christmas 递归

D - Christmas

 

Time limit : 2sec / Memory limit : 1024MB

Score : 400 points

Problem Statement

In some other world, today is Christmas.

Mr. Takaha decides to make a multi-dimensional burger in his party. A level-L burger (L is an integer greater than or equal to 0) is the following thing:

  • A level-0 burger is a patty.
  • A level-L burger (L≥1) is a bun, a level-(L−1) burger, a patty, another level-(L−1) burger and another bun, stacked vertically in this order from the bottom.

For example, a level-1 burger and a level-2 burger look like BPPPB and BBPPPBPBPPPBB (rotated 90 degrees), where B and P stands for a bun and a patty.

The burger Mr. Takaha will make is a level-N burger. Lunlun the Dachshund will eat X layers from the bottom of this burger (a layer is a patty or a bun). How many patties will she eat?

Constraints

  • 1≤N≤50
  • 1≤X≤( the total number of layers in a level-N burger )
  • N and X are integers.

 

Input

Input is given from Standard Input in the following format:

N X

Output

Print the number of patties in the bottom-most X layers from the bottom of a level-N burger.

 

Sample Input 1

Copy

2 7

Sample Output 1

Copy

4

There are 4 patties in the bottom-most 7 layers of a level-2 burger (BBPPPBPBPPPBB).

 

Sample Input 2

Copy

1 1

Sample Output 2

Copy

0

The bottom-most layer of a level-1 burger is a bun.

 

Sample Input 3

Copy

50 4321098765432109

Sample Output 3

Copy

2160549382716056

A level-50 burger is rather thick, to the extent that the number of its layers does not fit into a 32-bit integer.

 

Submit

解题思路:这题的题意是有一个字符串S[0]=’p’,S[i]=’b’+s[i-1]+’p’+s[i-1]+’b’,求s[i]前x个中有多少个‘p’字符。这道题用递归,因为字符串就是按递归出来的,所以我们讨论情况进行递归,具体过程见代码和注释。

#include<bits/stdc++.h>
using namespace std;
#define LL long long
#define pf printf
#define sf scanf
#define pn printf("\n");
#define pk printf(" ");
#define sfn scanf("%d",&n);
LL a[55]={1LL},p[55]={1LL};
LL solve(LL n,LL x)
{
	if(n==0&&x>=1)//当n=0,即为s[0]='p',只有一个'p' 
	return 1;
	else  if(x<=0)
	return 0;
	else if(x<=1+a[n-1])//即'b'+s[i-1]的范围里,继续递归s[i-1]里的情况,同时减去前面的一个'b' 
	    return solve(n-1,x-1);
	    else
	    return 1+p[n-1]+solve(n-1,x-2-a[n-1]);
	//即范围在'b'+s[i-1]+'p'+s[i-1]+'b'里 主要递归在后面的s[i-1]里, 
}//中间的一个'p'+前面s[i-1]部分的'p'的个数(p[n-1])+后面s[i-1]中继续递归下去的部分 
int main()
{
LL T,n,x;
	scanf("%lld %lld",&n,&x);
for(int i=1;i<55;i++)
{
	a[i]=a[i-1]*2+3;//s[i]的字符串总长度  
	p[i]=p[i-1]*2+1;//s[i]中'P'的个数 
	}	
	
	printf("%lld",solve(n,x));
 } 

猜你喜欢

转载自blog.csdn.net/explodee/article/details/84964147