hdu1501 记忆化搜索dfs

Zipper

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11557    Accepted Submission(s): 4156


 

Problem Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

 

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

 

 

Output

For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

 

Sample Input

 

3 cat tree tcraete cat tree catrtee cat tree cttaree

 

Sample Output

 

Data set 1: yes Data set 2: yes Data set 3: no

 

Source

Pacific Northwest 2004

 

Recommend

linle   |   We have carefully selected several similar problems for you:  1502 1227 1503 1078 1024 

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 1005
int vis[maxn][maxn];
char a[maxn];
char b[maxn];
char c[maxn*2];
bool dfs(int cc,int aa,int bb)
{if(c[cc]==0)
return true;
if(vis[aa][bb])

    return false;
    vis[aa][bb]=1;
if(c[cc]==a[aa])
   {

    if(dfs(cc+1,aa+1,bb))
    return true;}
if(c[cc]==b[bb])
   {

    if (dfs(cc+1,aa,bb+1))
    return true;
   }
   return false;
}
int main()
{
    int t;
    scanf("%d",&t);
    int w=0;
    while(t--)
    {memset(vis,0,sizeof(vis));
        w++;

        cin>>a>>b>>c;
        if(dfs(0,0,0))
            printf("Data set %d: yes\n",w);
        else
           printf("Data set %d: no\n",w);

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/84429348