Dragon of Loowater _UVA11292

题目

 Once upon a time, in the Kingdom of Loowater, a minor nuisance turned into a major problem. The shores of Rellau Creek in central Loowater had always been a prime breeding ground for geese. Due to the lack of predators, the geese population was out of control. The people of Loowater mostly kept clear of the geese. Occasionally, a goose would attack one of the people, and perhaps bite off a finger or two, but in general, the people tolerated the geese as a minor nuisance. One day, a freak mutation occurred, and one of the geese spawned a multi-headed fire-breathing dragon. When the dragon grew up, he threatened to burn the Kingdom of Loowater to a crisp. Loowater had a major problem. The king was alarmed, and called on his knights to slay the dragon and save the kingdom. The knights explained: “To slay the dragon, we must chop off all its heads. Each knight can chop off one of the dragon’s heads. The heads of the dragon are of different sizes. In order to chop off a head, a knight must be at least as tall as the diameter of the head. The knights’ union demands that for chopping off a head, a knight must be paid a wage equal to one gold coin for each centimetre of the knight’s height.” Would there be enough knights to defeat the dragon? The king called on his advisors to help him decide how many and which knights to hire. After having lost a lot of money building Mir Park, the king wanted to minimize the expense of slaying the dragon. As one of the advisors, your job was to help the king. You took it very seriously: if you failed, you and the whole kingdom would be burnt to a crisp! Input The input contains several test cases. The first line of each test case contains two integers between 1 and 20000 inclusive, indicating the number n of heads that the dragon has, and the number m of knights in the kingdom. The next n lines each contain an integer, and give the diameters of the dragon’s heads, in centimetres. The following m lines each contain an integer, and specify the heights of the knights of Loowater, also in centimetres. The last test case is followed by a line containing ‘0 0’. Output For each test case, output a line containing the minimum number of gold coins that the king needs to pay to slay the dragon. If it is not possible for the knights of Loowater to slay the dragon, output the line ‘Loowater is doomed!’. Sample Input 2 3 5 4 7 8 4 2 1 5 5 10 0 0 Sample Output 11 Loowater is doomed!

题目大意

 有一条恶龙,他有n个头,有m个骑士。

每个骑士只能砍死恶龙的一个头,而且只有骑士的身高大于恶龙偷得直径的时候才能将其砍死。

骑士将恶龙砍死,需要向骑士支付等同于骑士身高的金币

无限个测试样例,输入0 0结束测试

首先输入 n m

然后输入n个恶龙头的直径  输入m个骑士的身高

判断是否能够将恶龙砍死,如果能砍死,输出所需支付的最小金币

如果不能 输出Loowater is doomed!

算法: 贪心

代码 

#include <iostream>
#include <algorithm>
using namespace std;
int a[20005],b[20005];  //a恶龙 b骑士 
int main()
{
	int n,m,i,j;
	while(cin>>n>>m)
	{
		if(n==0 && m==0) break;
		for(i=0;i<n;i++)
		{
			cin>>a[i];
		}	
		for(i=0;i<m;i++)
		{
			cin>>b[i];
		}
		sort(a,a+n);
		sort(b,b+m);
		int ans=0,num=0,st=0;
		for(i=0;i<n;i++) 
			for(j=st;j<m;j++)      //j要从st开始,st代表现在判断到哪一个骑士了
			{
				if(b[j]>=a[i])    //只有升高大于等于直径才能满足要求
				{
					ans+=b[j];     //金币值
					num++;         //num用来判断砍死多少个头
					st=j+1;        //st用来标记 接下来要判断哪一个骑士
					break;
				} 
			}
		if(num<n) cout<<"Loowater is doomed!"<<endl;
		else cout<<ans<<endl;
	}
	return 0;
}

 解析

要求最小金币,那么肯定是要有限使用花费少的骑士(也就是身高小的)

将身高和半径排序

从小的开始匹配

也就是贪心 

猜你喜欢

转载自blog.csdn.net/baidu_41907100/article/details/84825938