Dragon of Loowater UVA - 11292 (思维的体操)

Once upon a time, in the
Kingdom of Loowater, a minor
nuisance turned into a
major problem.
The shores of Rellau
Creek in central Loowater
had always been a prime
breeding ground for geese.
Due to the lack of predators,
the geese population was out
of control. The people of
Loowater mostly kept clear
of the geese. Occasionally,
a goose would attack one of
the people, and perhaps bite
off a finger or two, but in
general, the people tolerated
the geese as a minor nuisance.
One day, a freak mutation
occurred, and one
of the geese spawned a
multi-headed fire-breathing
dragon. When the dragon grew up, he threatened to burn the Kingdom of Loowater to a crisp.
Loowater had a major problem. The king was alarmed, and called on his knights to slay the dragon
and save the kingdom.
The knights explained: “To slay the dragon, we must chop off all its heads. Each knight can chop
off one of the dragon’s heads. The heads of the dragon are of different sizes. In order to chop off a
head, a knight must be at least as tall as the diameter of the head. The knights’ union demands that
for chopping off a head, a knight must be paid a wage equal to one gold coin for each centimetre of the
knight’s height.”
Would there be enough knights to defeat the dragon? The king called on his advisors to help him
decide how many and which knights to hire. After having lost a lot of money building Mir Park, the
king wanted to minimize the expense of slaying the dragon. As one of the advisors, your job was to
help the king. You took it very seriously: if you failed, you and the whole kingdom would be burnt to
a crisp!
Input
The input contains several test cases. The first line of each test case contains two integers between 1 and
20000 inclusive, indicating the number n of heads that the dragon has, and the number m of knights in
the kingdom. The next n lines each contain an integer, and give the diameters of the dragon’s heads,
in centimetres. The following m lines each contain an integer, and specify the heights of the knights of
Loowater, also in centimetres.
The last test case is followed by a line containing ‘0 0’.
Output
For each test case, output a line containing the minimum number of gold coins that the king needs to
pay to slay the dragon. If it is not possible for the knights of Loowater to slay the dragon, output the
line ‘Loowater is doomed!’.
Sample Input
2 3
5
4
7
8
4
2 1
5
5
10
0 0
Sample Output
11
Loowater is doomed!
题意:有n头龙,m个骑士,能力为x的起始可砍一条直径不超过x的龙,且需要支付x金币,每个骑士只能雇佣一次。如和雇佣骑士且支付的金币最少。如果无解则输出Loowater is doomed!;
思路: 将龙和骑士按从小到大排序,如果骑士能杀死恶龙就雇佣,否则跳过该骑士,直到恶龙全部被杀死或骑士雇佣完结束。
AC的C++程序如下:

#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
const int N = 20005;
int n, m;
int dragon[N], hero[N];//分别为龙和勇士
int main()
{
    while (cin>>n>>m)
    {
        if (n == 0 && m == 0) break;
        for (int i = 0; i < n; i++)
        {
            cin >>dragon[i];
        }
        for (int i = 0; i < m; i++)
        {
            cin >> hero[i];
        }
        sort(dragon, dragon + n);
        sort(hero, hero + m);
        int sum = 0;//所需的金币数
        int len = 0;//所杀的恶龙数目
        for (int i = 0; i < m; i++) //模拟雇佣骑士杀恶龙
        {
            if (hero[i]<dragon[len])
            {
                continue;
            }
            sum += hero[i];
            len++;
            if (len == n) break;
        }
        if (len < n)
        {
            cout << "Loowater is doomed!" << endl;
        }
        else
        {
            cout << sum << endl;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/jinduo16/article/details/81736681