2018年 ACM/ICPC亚洲区域赛 青岛赛区现场赛 F题(ZOJ 4063 思维)

DreamGrid, the king of Gridland, is making a knight tournament. There are  knights, numbered from 1 to , participating in the tournament. The rules of the tournament are listed as follows:

The tournament consists of  rounds. Each round consists of several duels. Each duel happens between exactly two knights.
Each knight must participate in exactly one duel during each round.
For each pair of knights, there can be at most one duel between them during all the  rounds.
Let , , and ,  be four distinct integers. If
Knight  fights against knight  during round , and
Knight  fights against knight  during round , and
Knight  fights against knight  during round ,
then knight  must fight against knight  during round .
As DreamGrid's general, you are asked to write a program to arrange all the duels in all the  rounds, so that the resulting arrangement satisfies the rules above.

Input

There are multiple test cases. The first line of the input is an integer , indicating the number of test cases. For each test case:

The first and only line contains two integers  and  (), indicating the number of knights participating in the tournament and the number of rounds.

It's guaranteed that neither the sum of  nor the sum of  in all test cases will exceed 5000.

Output

For each test case:

If it's possible to make a valid arrangement, output  lines. On the -th line, output  integers  separated by one space, indicating that in the -th round, knight  will fight against knight  for all .

If there are multiple valid answers, output the lexicographically smallest answer.

Consider two answers  and , let's denote  as the -th integer on the -th line in answer , and  as the -th integer on the -th line in answer . Answer  is lexicographically smaller than answer , if there exists two integers  () and  (), such that

for all  and , , and
for all , , and finally .
 

If it's impossible to make a valid arrangement, output "Impossible" (without quotes) in one line.
Please, DO NOT output extra spaces at the end of each line, or your answer may be considered incorrect!

Sample Input

2
3 1
4 3
Sample Output

Impossible
2 1 4 3
3 4 1 2
4 3 2 1

题意:T组样例,每组给你n表示n个人,m表示要打m轮比赛。每一轮每个人都要有一个对手。而且每个对手只能打一次。假设a与b打了,c与d打了,那么下一轮如果a与c打了,那么b就必须和d打。

问你这m轮比赛怎么安排。如果无法安排,输出Impossible。

如果有,m行,每行输出每个人的对手是几号。

思路:比赛的时候思维僵化了。

问题转化为找到m个二阶置换{f_i},使得对于任意i!=j都有f_i(a)!=f_j(a)且f_i(f_j(a))=f_j(f_i(a))。

再想一想异或的性质,你马上就会做了。
 

#include<bits/stdc++.h>
#define ll long long
#define maxn 200010
using namespace std;
int n,m,k;
int main()
{
    int T,cas=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        if(m>=(n&(-n))) {puts("Impossible");continue;}
        for(int j=1;j<=m;j++)
        for(int i=0;i<n;i++)
        {
            printf("%d%c",(i^j)+1,i==n-1?'\n':' ');
        }
    }
    return 0;
}

抄的大神博客

猜你喜欢

转载自blog.csdn.net/mlm5678/article/details/84351552