hdoj 2051 Bitset

Bitset

Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
 

Input
For each case there is a postive number n on base ten, end of file.
 

Output
For each case output a number on base two.
 

Sample Input
 
   
1 2 3
 

Sample Output
1
 
   
10 11
 

Author
8600 && xhd
首先介绍一个函数   itoa (i ,num ,10 );
i ---- 需要转换成字符串的数字
num ---- 转换后保存字符串的变量
10 ---- 转换数字的基数(即进制)。10就是说按10进制转换数字。还可以是2,8,16等等你喜欢的进制类型
返回值:指向num这个字符串的 指针
#include<stdio.h>
    #include<stdlib.h>
    int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		char str[4000];
		itoa(n,str,2);
		printf("%s\n",str);
	}
	return 0;
    }



猜你喜欢

转载自blog.csdn.net/dear_jia/article/details/80071251
今日推荐