6126 Problem A Set Similarity (25)

问题 A: Set Similarity (25)

时间限制: 1 Sec  内存限制: 32 MB
提交: 252  解决: 106
[提交][状态][讨论版][命题人:外部导入]

题目描述

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

输入

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

输出

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

样例输入

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

样例输出

50.0%
33.3%
#include<iostream>
#include<set>
using namespace std;
//原想用map,没想到直接set就过了
int main() {
	int n, k;
	while (cin >> n) {
		set<int> s[100];
		for (int i = 1; i <= n; i++) {
			int num;
			cin >> num;
			for (int j = 0; j < num; j++) {
				int x;
				cin >> x;
				s[i].insert(x);
			}
		}
		cin >> k;
		while (k--) {
			int x, y;
			cin >> x >> y;
			int Nc = 0, Nt = s[y].size();
			for (set<int>::iterator it = s[x].begin(); it != s[x].end(); it++) {
				if (s[y].find(*it) != s[y].end()) Nc++;
				else Nt++;
			}
			printf("%.1f%%\n", 100.0*Nc / Nt);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36502291/article/details/84484742