Set Similarity

问题 A: Set Similarity (25)
时间限制: 1 Sec 内存限制: 32 MB
提交: 292 解决: 126
[提交][状态][讨论版][命题人:外部导入]
题目描述
Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.
输入
Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.
输出
For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.
样例输入
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
样例输出
50.0%
33.3%
自己代码:

#include<iostream>
#include<set>
using namespace std;
int main() {
	int N,num,element;
	int search[2];
	double shuchu[2000];
	set<int> input[50];
	while (scanf("%d", &N) != EOF) {//共有N组set输入
		int jishu = 0;
	    for (int i = 0; i < N; i++)
		{
			scanf("%d", &num);//每组set有几个数
			for (int j = 0; j < num; j++) {
				scanf("%d", &element);
				input[i].insert(element);
			}
		}
		//输入要查询的set组数
		scanf("%d", &num);
		for (int i = 0; i < num; i++) {
			scanf("%d %d", &search[0], &search[1]);
			//查找相同的个数
			int Nc = input[search[0] - 1].size() + input[search[1] - 1].size();
			set<int> merge;//取出要查询的两个set的合并
			for (set<int>::iterator it = input[search[0] - 1].begin(); it != input[search[0] - 1].end();
				it++) {
				merge.insert(*it);
			}
			for (set<int>::iterator it = input[search[1] - 1].begin(); it != input[search[1] - 1].end();
				it++) {
				merge.insert(*it);
			}
			int Nt = merge.size();
			Nc = Nc - Nt;
			double result = (double)Nc / (double)Nt * 100;
			shuchu[jishu++] = result;
		}
		for (int i = 0; i < jishu; i++)
			printf("%.1f%%\n", shuchu[i]);
	}
	
	system("pause");
	return 0;
}

注意:本题练习的是set容器的用法,set的主要用途是自动去重并按升序排序,若需要处理不唯一的情况,则需要使用multiset,另外还增加了unordered_set,以散列代替内部红黑树。要读懂题意。

猜你喜欢

转载自blog.csdn.net/qq_35966478/article/details/86665727