1063 Set Similarity (25 分)【STL中vector与set的使用】

1063 Set Similarity (25 分)

Given two sets of integers, the similarity of the sets is defined to be N​c​​/N​t​​×100%, where N​c​​ is the number of distinct common numbers shared by the two sets, and N​t​​ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10​4​​) and followed by M integers in the range [0,10​9​​]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

题意:公共元素个数除以2个set不同元素的总个数,如例子:set1和set2中2个公共元素,总共4个不相同的元素

解题思路:这个一看就是不要重复的,那肯定使用set比较方便,但是有多个set,所以用vector来储存这些set,然后我们直接从b找a的元素,找得到就是count1加1即公共元素,找不到就count2加1,那这2个set中总共count2+b的个数,应该get得到吧,具体实现在下面

#include<bits/stdc++.h>
using namespace std;
vector<set<int> >v;
int main(void)
{
	int n;
	scanf("%d",&n);
	v.resize(n+1);
	for(int i=1;i<=n;i++)
	{
		int m;
		scanf("%d",&m);
		for(int j=0;j<m;j++)
		{
			int a;
			scanf("%d",&a);
			v[i].insert(a);
		}
	}
	int k,a,b;
	scanf("%d",&k);
	while(k--)
	{
		scanf("%d %d",&a,&b);
		int len1=v[a].size(),len2=v[b].size(),count1=0,count2=0;
	//	cout<<len1<<" "<<len2<<endl;
		for(auto i=v[a].begin();i!=v[a].end();i++)
		{
		//	cout<<*i<<endl;
			if(v[b].count(*i)!=0) 	count1++;
			else count2++;
		}
	 //  cout<<count1<<" "<<count2<<" "<<count2+len2<<endl;
		printf("%.1lf%\n",count1*1.0/(count2+len2)*100);
	}
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/84104807