1063 Set Similarity (25point(s))

1063 Set Similarity (25point(s))

Given two sets of integers, the similarity of the sets is defined to be N
​c
​​ /N
​t
​​ ×100%, where N
​c
​​ is the number of distinct common numbers shared by the two sets, and N
​t
​​ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:
Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10
​4
​​ ) and followed by M integers in the range [0,10
​9
​​ ]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:
For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
Sample Output:
50.0%
33.3%

超时

#include<bits/stdc++.h>
using namespace std;
set<int> st[55];
int main(){
    
    
    int n,m;
    cin>>n;
    for(int i=1;i<=n;++i){
    
    
        int num,k;
        cin>>k;
        while(k--){
    
    
            cin>>num;
            st[i].insert(num);
        }
    }
    cin>>m;
    int first,second;
    for(int i=0;i<m;++i){
    
    
        set<int> temp;
        cin>>first>>second;
        for(set<int>::iterator it=st[first].begin();it!=st[first].end();++it)
            temp.insert(*it);
        for(set<int>::iterator it=st[second].begin();it!=st[second].end();++it)
            temp.insert(*it);
        printf("%.1lf%\n",(st[first].size()+st[second].size()-temp.size())*100.0/temp.size());
    }
}
#include<bits/stdc++.h>
using namespace std;
set<int> st[55];
int main(){
    
    
    int n,m;
    cin>>n;
    for(int i=1;i<=n;++i){
    
    
        int num,k;
        cin>>k;
        while(k--){
    
    
            cin>>num;
            st[i].insert(num);
        }
    }
    cin>>m;
    int first,second;
    for(int i=0;i<m;++i){
    
    
        int sameNum=0;
        cin>>first>>second;
        for(auto it=st[first].begin();it!=st[first].end();++it){
    
    
            if(st[second].find(*it)!=st[second].end()) sameNum++;
        }
        printf("%.1lf%\n",sameNum*100.0/(st[first].size()+st[second].size()-sameNum));
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_44970602/article/details/111713251