【二叉树】SDUT 3341 遍历二叉树

Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

每组输入数据对应输出2行:
第1行输出中序遍历序列;
第2行输出后序遍历序列。

Sample Input

abc,,de,g,,f,,,

Sample Output

cbegdfa
cgefdba 
#include <stdio.h>
#include <stdlib.h>
typedef struct no
{
    char data;
    struct no *lc,*rc;
}node;
int l;
node *creat(char a[])
{
    char c;
    node *root;
    if(!a[l])
        return NULL;
    root=(node*)malloc(sizeof(node));
    c=a[l++];
    if(c==',')return NULL;
    root->data=c;
    root->lc=creat(a);
    root->rc=creat(a);
    return root;
}
void mid(node *root)
{
    if(root)
    {
        mid(root->lc);
        printf("%c",root->data);
        mid(root->rc);
    }

}
void after(node *root)
{
    if(root)
    {
        after(root->lc);
        after(root->rc);
        printf("%c",root->data);
    }
}
int main()
{
    char a[60];
    node *root;
    while(~scanf("%s",a))
    {
        l=0;
        root=creat(a);

        mid(root);
        printf("\n");

        after(root);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/flyf000/article/details/83616775