习题6-8 统计一行文本的单词个数 (15 point(s))

习题6-8 统计一行文本的单词个数 (15 point(s))

本题目要求编写程序统计一行字符中单词的个数。所谓“单词”是指连续不含空格的字符串,各单词之间用空格分隔,空格数可以是多个。

输入格式:

输入给出一行字符。

输出格式:

在一行中输出单词个数。

输入样例:

Let's go to room 209.

输出样例:

5
#include<stdio.h>
int main(){
  char str[1001];
  gets(str);
  int count=0;
  int i=0;
  while(str[i]==' ')
  	i++;
  	while(str[i]!='\0'){
	  if(str[i]!=' '){
	  	count++;
	   	while(str[i]!=' '){
		   
	  		if(str[i]=='\0')
	  		break;
	  	 i++;
		  
	  }
	}
	  else
	  	i++;
	  
	  }
	  printf("%d",count);
	  
}

猜你喜欢

转载自blog.csdn.net/qq_42057358/article/details/84035900