习题6-1 分类统计字符个数 (15point(s)).c

本题要求实现一个函数,统计给定字符串中英文字母、空格或回车、数字字符和其他字符的个数。

函数接口定义:

void StringCount( char s[] );

其中 char s[] 是用户传入的字符串。函数StringCount须在一行内按照

letter = 英文字母个数, blank = 空格或回车个数, digit = 数字字符个数, other = 其他字符个数的格式输出。

裁判测试程序样例:

#include <stdio.h>
#define MAXS 15

void StringCount( char s[] );
void ReadString( char s[] ); /* 由裁判实现,略去不表 */

int main()
{
    char s[MAXS];

    ReadString(s);
    StringCount(s);

    return 0;
}

/* Your function will be put here */

      

输入样例:

aZ &
09 Az

输出样例:

letter = 4, blank = 3, digit = 2, other = 1

Note: only implement void stringcount (char s []) function!!!

//   Date:2020/3/31
//   Author:xiezhg5
#include <stdio.h>
#define MAXS 15

void StringCount( char s[] );
void ReadString( char s[] ); /* 由裁判实现,略去不表 */

int main()
{
    char s[MAXS];

    ReadString(s);
    StringCount(s);

    return 0;
}

/* Your function will be put here */
void ReadString( char s[] )
{
	int i;
	for(i=0;i<MAXS;i++)
	scanf("%c",&s[i]);
}
void StringCount( char s[] )
{
	int count1=0,count2=0,count3=0,count4=0;
	int i;
	for(i=0;s[i]!='\0';i++)
	{
		if((s[i]>='a'&&s[i]<='z')||(s[i]>='A'&&s[i]<='Z'))
			count1++;
		//注意一定要用else if 
		else if(s[i]==' '||s[i]=='\n')
			count2++;
		else if(s[i]>='0'&&s[i]<='9')
			count3++;
		else
			count4++;
	}
	printf("letter = %d, blank = %d, digit = %d, other = %d\n",count1,count2,count3,count4);
}
发布了165 篇原创文章 · 获赞 124 · 访问量 5653

猜你喜欢

转载自blog.csdn.net/qq_45645641/article/details/105230817