习题6-8 统计一行文本的单词个数 (15 分)

本题目要求编写程序统计一行字符中单词的个数。所谓“单词”是指连续不含空格的字符串,各单词之间用空格分隔,空格数可以是多个。

输入格式:
输入给出一行字符。

输出格式:
在一行中输出单词个数。

输入样例:
Let’s go to room 209.
输出样例:
5

#include<stdio.h>
#include<string.h>
int main()
{
	int sum,i,count=0;
	char a[1000];//注意条件数组元素要足够多
	gets(a);
	sum=strlen(a);/*最后输入的回车gets将其转化为'\0',且可以输入空格,scanf则不能输入空格默认输入结束。*/
	for(i=0;i<sum;i++)
	{
if(a[i]!=' '&&(a[i+1]==' '||a[i+1]=='\0'))
		count++;
}

	printf("%d",count);

	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43813373/article/details/85450149