POJ - 1947 Rebuilding Roads 树形dp+分组背包

The cows have reconstructed Farmer John's farm, with its N barns (1 <= N <= 150, number 1..N) after the terrible earthquake last May. The cows didn't have time to rebuild any extra roads, so now there is exactly one way to get from any given barn to any other barn. Thus, the farm transportation system can be represented as a tree.

Farmer John wants to know how much damage another earthquake could do. He wants to know the minimum number of roads whose destruction would isolate a subtree of exactly P (1 <= P <= N) barns from the rest of the barns.

Input

* Line 1: Two integers, N and P

* Lines 2..N: N-1 lines, each with two integers I and J. Node I is node J's parent in the tree of roads.

Output

A single line containing the integer that is the minimum number of roads that need to be destroyed for a subtree of P nodes to be isolated.

Sample Input

11 6
1 2
1 3
1 4
1 5
2 6
2 7
2 8
4 9
4 10
4 11

Sample Output

2

Hint

[A subtree with nodes (1, 2, 3, 6, 7, 8) will become isolated if roads 1-4 and 1-5 are destroyed.]

题解:dp[i][j] 表示以i这个节点 和子代连接 如果保存j个节点的话 需要去除多少遍  显然dp[i][1] 就是i子代的个数 因为你只能从一个子代那里 更新一个状态  一次  显然这是一个分组背包  因为该节点必须要所以更新到2就可以了 在最后取最小值时,若该点不是根节点 需要在结果的基础上+1,因为该点还与父节点连接着

#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
using namespace std;
#define INF 0x3f3f3f3f
const int N=150+10;
vector<int> v[N];
int dp[N][N],in[N];
int n,m;
void dfs(int u)
{
	dp[u][1]=v[u].size();//
	for(int i=0;i<v[u].size();i++)
	{
		int to=v[u][i];
		dfs(to);
		for(int j=m;j>=2;j--)
			for(int k=1;k<j;k++)
				dp[u][j]=min(dp[u][j],dp[to][k]+dp[u][j-k]-1);// 这个地方 坑点 若和子代连接 那么这条边就不去了 
	}	
} 
int main()
{
	int x,y;
	while(~scanf("%d%d",&n,&m))
	{
		for(int i=1;i<=n;i++) v[i].clear();
		for(int i=1;i<n;i++)
		{
			scanf("%d%d",&x,&y);
			v[x].push_back(y);
		}
		memset(dp,INF,sizeof(dp));
		dfs(1);
		int ans=dp[1][m];
		for(int i=2;i<=n;i++) ans=min(ans,dp[i][m]+1);
		printf("%d\n",ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/mmk27_word/article/details/84068961