M - Function and Function (思维题)

If we define , do you know what function  means?

Actually,  calculates the total number of enclosed areas produced by each digit in . The following table shows the number of enclosed areas produced by each digit:

Enclosed Area Digit Enclosed Area Digit
0 1 5 0
1 0 6 1
2 0 7 0
3 0 8 2
4 1 9 1

For example, , and .

We now define a recursive function  by the following equations:

For example, , and .

Given two integers  and , please calculate the value of .

Input

There are multiple test cases. The first line of the input contains an integer (about ), indicating the number of test cases. For each test case:

The first and only line contains two integers  and  (). Positive integers are given without leading zeros, and zero is given with exactly one '0'.

Output

For each test case output one line containing one integer, indicating the value of .

Sample Input

6
123456789 1
888888888 1
888888888 2
888888888 999999999
98640 12345
1000000000 0

Sample Output

5
18
2
0
0
1000000000

Hint

题目没有粘全。。。。。

关键是有技巧。。

就是所有的数在经过题目中的条件下,一定的循环后一定会变成0,这个时候单独处理就不会超时。。。

#include <iostream>
#include <bits/stdc++.h>
#define INF 0x3f3f3f3f
using namespace std;
int main()
{
    int T;
    int x,k;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&x,&k);
        if(k==0)
            printf("%d\n",x);
        else
        {
            int ans;
            while(k--)
            {
                ans = 0;
                if(x==0)
                {
                    if(k%2==0)
                        ans = 1;
                    else
                        ans = 0;
                    break;
                }
                while(x)
                {
                    int j = x%10;
                    if(j==0||j==4||j==6||j==9)
                        ans+=1;
                    else if(j==8)
                        ans+=2;
                    else ans+=0;
                    x/=10;
                }
                x = ans;
            }
            printf("%d\n",ans);
        }
    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/ACMerdsb/article/details/83926538