HDU - 1285——确定比赛名次

有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。

Input

输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。

Output

给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。

Sample Input

4 3
1 2
2 3
4 3

Sample Output

1 2 4 3

拓扑排序模板+优先队列

#include<algorithm>
#include<string.h>
#include<stdio.h>
#include<vector>
#include<queue>
using namespace std;
priority_queue<int,vector<int>,greater<int> >q;
vector<int>p[510];
int topu[510],ans[510];
int main()
{
    int n,m,x,y;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=n;i++)
            p[i].clear();
        memset(topu,0,sizeof(topu));
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&x,&y);
            p[x].push_back(y);
            topu[y]++;
        }
        for(int i=1;i<=n;i++)
        {
            if(topu[i]==0)
            {
                q.push(i);
            }
        }
        int v,tot=1;
        while(!q.empty())
        {
            v=q.top();
            q.pop();
            int d=p[v].size();
            for(int i=0;i<d;i++)
            {
                int u=p[v][i];
                topu[u]--;
                if(topu[u]==0)
                    q.push(u);
            }
            ans[tot++]=v;
        }
        if(tot>=1)
        printf("%d",ans[1]);
        for(int i=2;i<tot;i++)
            printf(" %d",ans[i]);
        printf("\n");
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_41380961/article/details/83420022