POJ 2976 二分之最大化平均值问题

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains npositive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

题目大意:从n对数选择n-k对数,使其运算上面的式子,然后求最大的平均值

分析:如果这题知道是最大化平均值的话,肯定就知道是通过二分来实现的,网上也有解释为什么这样做的,但是却很少有证明的,但是我无意中找到一篇大佬的详解,最大化平均值问题可以叫做01分数规划问题;复杂度为O(nlogn)

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
const int N = 3e5 + 10;
const int MOD = 0x3f3f3f3f;
int k,n;
bool vis[N];
double ans,temp;
struct node{
    double a,b;
}num[N];
double y[N];
bool solve(double x)
{
    rep(i,1,n)
    y[i]=num[i].a-x*num[i].b;
    sort(y+1,y+1+n);
    double sum=0;
    for(int i=n;i>k;i--) sum+=y[i];
    return sum>=0;
}
int main()
{
    #ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    #endif // ONLINE_JUDGE
    while(scanf("%d%d",&n,&k)!=EOF,n+k){
            rep(i,1,n) scanf("%lf",&num[i].a);
            rep(i,1,n) scanf("%lf",&num[i].b);
            double l=0,r=MOD*1.0;
            for(int i=1;i<=100;i++){
                double mid=(l+r)/2;
                if(solve(mid)) l=mid;
                else r=mid;
            }
            printf("%.f\n",l*100.0);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/c___c18/article/details/83338333
今日推荐