[二分-最大化平均值]poj-2976

Dropping tests
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15588   Accepted: 5440

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).


题意:

给出n个二元组(a,b),删除k个二元组,使得剩下的a元素之和与b元素之和的比率最大(比率最后*100)

题解:

最大化平均值 : 01分数规划

最裸的01分数规划
    设x[i]属于{0,1},表示第i个元组是否留下,p为比率,P为p的最大值,即比例的最大值(注意区分P和p)
    则 p = sigma(ai*xi) / sigma(bi*ai),其中sigma(xi) = n-k; -> 表示有n-k个1
    显然;对于所有可能取得的p的值,p <= P;
    即对于所有可能的xi的组合,sigma(ai*xi) / sigma(bi*xi) <= P
    即sigma(ai*xi) / sigma(bi*xi)的最大值就是等于P的
    于是对于p sigma(ai*xi) - sigma(bi*xi*p) > 0;当 p < P;
    当p = P时 ,sigma(ai*xi) - sigma(bi*xi*p) == 0;
    当p > P,时 sigma(ai*xi) - sigma(bi*xi*p) < 0


    我们要二分寻找p,使得p无限接近P. 于是 当 max(sigma(ai*xi) - sigma(bi*xi*p)) >= 0 时 说明此时满足情况,需要最大化向右搜
    否则向左搜

代码:

/**
    最大化平均值 : 01分数规划
    给出n个二元组(a,b),删除k个二元组,使得剩下的a元素之和与b元素之和的比率最大(比率最后*100)
    题解:最裸的01分数规划
    设x[i]属于{0,1},表示第i个元组是否留下,p为比率,P为p的最大值,即比例的最大值(注意区分P和p)
    则 p = sigma(ai*xi) / sigma(bi*ai),其中sigma(xi) = n-k; -> 表示有n-k个1
    显然;对于所有可能取得的p的值,p <= P;
    即对于所有可能的xi的组合,sigma(ai*xi) / sigma(bi*xi) <= P
    即sigma(ai*xi) / sigma(bi*xi)的最大值就是等于P的
    于是对于p sigma(ai*xi) - sigma(bi*xi*p) > 0;当 p < P;
    当p = P时 ,sigma(ai*xi) - sigma(bi*xi*p) == 0;
    当p > P,时 sigma(ai*xi) - sigma(bi*xi*p) < 0

    我们要二分寻找p,使得p无限接近P. 于是 当 max(sigma(ai*xi) - sigma(bi*xi*p)) >= 0 时 说明此时满足情况,需要最大化向右搜
    否则向左搜

*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 1e3+10;
const int inf = 1e9+10;
const double eps = 1e-6;
int arr[maxn],tot[maxn];
double ans[maxn];
int n,k;
bool check(double mid)
{
    for(int i=0;i<n;i++) {
        ans[i] = ((double)arr[i] - mid * tot[i]);
    }
    sort(ans,ans+n);
    double sum = 0;
    for(int i=k;i<n;i++) {
        sum += ans[i];
    }
    return sum >= 0;
}
int main()
{
    while(~scanf("%d%d",&n,&k),n+k)
    {
        for(int i=0;i<n;i++) scanf("%d",&arr[i]);
        for(int i=0;i<n;i++) scanf("%d",&tot[i]);
        double left = 0,right = inf;
        while(left + eps < right) {
            double mid = (left + right) / 2;
            if(check(mid)) left = mid;
            else right = mid;
        }
        right = right * 100;
        printf("%.0f\n",right);
    }
}

猜你喜欢

转载自blog.csdn.net/m0_38013346/article/details/79966823
今日推荐