POJ2976

Dropping tests

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 17511   Accepted: 6079

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains npositive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

Source

Stanford Local 2005

01分数规划

#include <iostream>
#include <algorithm>
using namespace std;
typedef long long ll;
const int maxn = 1005;

int s[maxn], c[maxn];
int n, k;
double a[maxn] , l, mid , r = 1e9;

int ok(double x)
{
    for(int i = 1;i <= n;i ++)
        a[i] = 1.0 * s[i] - x * c[i];

    sort(a + 1,a + n + 1);

    double sum = 0;
    for(int i = k + 1;i <= n;i ++)
        sum += a[i];

    return sum > 0;
}

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);

    while(cin >> n >> k && n && k)
    {
        l = 0;
        r = 1e9;

        for(int i = 1;i <= n;i ++)
            cin >> s[i];
        for(int i = 1;i <= n;i ++)
            cin >> c[i];

        while(r - l > 1e-3)
        {
            mid = (r + l) * 0.5;
            if(ok(mid)) l = mid;
            else r = mid;
        }
        int ans = round(l * 100);
        cout << ans << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Soul_97/article/details/81367988