解题报告 之 ZOJ 3829 Known Notation

解题报告 之 ZOJ 3829 Known Notation



Description

Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven't learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations to make it valid. There are two types of operation to adjust the given string:

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input

3
1*1
11*234**
*

Sample Output

1
0
2


题目大意:给你一个由1~9数字和*构成的逆波兰计算式。可以向其中加入任意空格以将这个表达式分开,如果是合法的逆波兰式,则输出0。否则通过两种操作来将之变成合法的,一种是在任意位置插入数字或者*;一种是将换任意两个字符的位置。问要变成合法的,至少要执行几次操作。

分析:首先审题要清晰,这个题是可以出现多位数的, 操作数并不一定是1~9,只是说由1~9构成。观察式子发现第i个*前至少有i+1个数字。所以先扫描一遍字符串,统计数字数量num 和*号数量sym。如果num<sym+1,那么至少要添加sym+1-num个数字。所以采用贪心的策略,将这些添加用在一开始,因为添加只用了一步就解决了问题,而且添加最少也会耗费一步。从左往右扫描一遍字符串,动态更新Num和Sym,如果发现Num<Sym+1,先使用添加,如果添加用完,则和后面的数字交换。

上代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<stack>
#include<string>
using namespace std;

int main()
{
	int T;
	scanf( "%d", &T );
	string str;
	while(T--)
	{
		cin >> str;
		int num=0, sym=0;
		int ans=0;
		int l = str.length();
		for(int i = 0; i < l; i++)
		{
			if(str[i] == '*')	sym++;
		}
		
		int add = max(0,sym + 1 - (l - sym));
		ans += add;
		
		int Num = 0, Sym = 0;
		for(int i = 0; i < l; i++)
		{
			if(str[i] != '*')
				Num++;
			else
			{
				Sym++;
				if(Num < Sym + 1)
				{
					if(add > 0)
					{
						add--;
						Num++;
					}
					else
					{
						Num++;
						Sym--;
						ans++;
					}
				}
			}
		}
		printf( "%d\n", ans );
	}


	return 0;
}

就是这样,区域赛靠叔叔拿铜。~~

猜你喜欢

转载自blog.csdn.net/maxichu/article/details/48845367
ZOJ
今日推荐