Hdu 3829 Cat VS Dog

题目:

The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child's like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child's like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.

Input

The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child's like-animal and dislike-animal, C for cat and D for dog. (See sample for details)

Output

For each case, output a single integer: the maximum number of happy children.

Sample Input

1 1 2
C1 D1
D1 C1

1 2 4
C1 D1
C1 D1
C1 D2
D2 C1

Sample Output

1
3     

代码如下:

#include <cstdio>
#include <algorithm>
#include <iostream>
#include <cstring>
using namespace std;
const int maxn=505;
int n,m,p;
int a[maxn][maxn];
int match[maxn];
char dli[maxn][5];
char li[maxn][5];
int vis[maxn];
bool Find(int x)
{
    for (int i=0;i<p;i++)
    {
        if(!vis[i]&&a[x][i])
        {
            vis[i]=1;
            if(match[i]==-1||Find(match[i]))
            {
                match[i]=x;
                return true;
            }
        }
    }
    return false;
}
int algor ()
{
    memset (match,-1,sizeof(match));
    int ans=0;
    for (int i=0;i<p;i++)
    {
        memset (vis,0,sizeof(vis));
        if(Find(i)) ans++;
    }
    return ans;
}
int main()
{
    while(scanf("%d%d%d",&n,&m,&p)!=EOF)
    {
        memset (a,0,sizeof(a));
        for (int i=0;i<p;i++)
        {
            scanf("%s %s",li[i],dli[i]);
            for (int j=0;j<i;j++)
            {
                if(strcmp(li[i],dli[j])==0||strcmp(dli[i],li[j])==0)
                {
                    a[i][j]=1;
                    a[j][i]=1;
                }
            }
        }
        printf("%d\n",p-algor()/2);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/88375278
Dog
cat