C Halt Problem

C Halting Problem

In computability theory, the halting problem is the problem of determining, from a description of an arbitrary computer program, whether the program will finish running (i.e., halt) or continue to run forever.

Alan Turing proved in 1936 that a general algorithm to solve the halting problem cannot exist, but DreamGrid, our beloved algorithm scientist, declares that he has just found a solution to the halting problem in a specific programming language -- the Dream Language!

Dream Language is a programming language consists of only 5 types of instructions. All these instructions will read from or write to a 8-bit register r, whose value is initially set to 0. We now present the 5 types of instructions in the following table. Note that we denote the current instruction as the i-th instruction.

Instruction Description
add v Add v to the register r. As r is a 8-bit register, this instruction actually calculates (r+v)mod256 and stores the result into r, i.e. r←(r+v)mod256. After that, go on to the (i+1)-th instruction.
beq v k If the value of r is equal to v, jump to the k-th instruction, otherwise go on to the (i+1)-th instruction.
bne v k If the value of r isn't equal to v, jump to the k-th instruction, otherwise go on to the (i+1)-th instruction.
blt v k If the value of r is strictly smaller than v, jump to the k-th instruction, otherwise go on to the (i+1)-th instruction.
bgt v k If the value of r is strictly larger than v, jump to the k-th instruction, otherwise go on to the (i+1)-th instruction.

A Dream Language program consisting of n instructions will always start executing from the 1st instruction, and will only halt (that is to say, stop executing) when the program tries to go on to the (n+1)-th instruction.

As DreamGrid's assistant, in order to help him win the Turing Award, you are asked to write a program to determine whether a given Dream Language program will eventually halt or not.

Input

There are multiple test cases. The first line of the input is an integer T, indicating the number of test cases. For each test case:

The first line contains an integer n (1≤n≤10​4​​), indicating the number of instructions in the following Dream Language program.

For the following n lines, the i-th line first contains a string s (s∈{“add”,“beq”,“bne”,“blt”,“bgt”}), indicating the type of the i-th instruction of the program.

  • If s equals to "add", an integer v follows (0≤v≤255), indicating the value added to the register;
  • Otherwise, two integers v and k follow (0≤v≤255, 1≤k≤n), indicating the condition value and the destination of the jump.

It's guaranteed that the sum of n of all test cases will not exceed 10​5​​.

Output

For each test case output one line. If the program will eventually halt, output "Yes" (without quotes); If the program will continue to run forever, output "No" (without quotes).

Sample Input

4
2
add 1
blt 5 1
3
add 252
add 1
bgt 252 2
2
add 2
bne 7 1
3
add 1
bne 252 1
beq 252 1

Sample Output

Yes
Yes
No
No

Hint

For the second sample test case, note that r is a 8-bit register, so after four "add 1" instructions the value of r will change from 252 to 0, and the program will halt.

For the third sample test case, it's easy to discover that the value of r will always be even, so it's impossible for the value of r to be equal to 7, and the program will run forever.

题意:对于不同的指令做出相应的动作,add加值,b开头的如果符合条件就跳转至目标步骤。

一开始想模拟,但是死循环的模拟就出不来了,卡住了。

可以用记录每一步和当前值来判断这个情况是否出现过,还可以记录每一步骤出现过的次数,如果运行超过256次(数字最大就256种),那一定是死循环了;如果不是死循环,那么就可以执行到n+1。

#include<bits/stdc++.h>
#define mod 256
#define maxn 10005
using namespace std;

int a[maxn],v[maxn],k[maxn],vis[maxn][259];
string s[maxn];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            cin>>s[i];
            if(s[i][0]=='a')
                cin>>a[i];
            else
                cin>>v[i]>>k[i];
        }
        int r=0,now=1;
        memset(vis,0,sizeof(vis));
        while(now<=n)
        {
            if(r>256)   r%=mod;
            if(vis[now][r])break;
            vis[now][r]=1;
            if(s[now][0]=='a')
                r+=a[now++];
            else if(s[now]=="beq")
            {
                if(r==v[now])
                    now=k[now];
                else now++;
            }
            else if(s[now]=="bne")
            {
                if(r!=v[now])
                    now=k[now];
                else now++;
            }
            else if(s[now]=="blt")
            {
                if(r<v[now])
                    now=k[now];
                else now++;
            }
            else if(s[now]=="bgt")
            {
                if(r>v[now])
                    now=k[now];
                else now++;
            }

        }
        printf("%s\n",now==n+1?"YES":"NO");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sadsummerholiday/article/details/82817472