1082 Read Number in Chinese (25 分)字符串处理

1082 Read Number in Chinese (25 分)

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output Fu first if it is negative. For example, -123456789 is read as Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu. Note: zero (ling) must be handled correctly according to the Chinese tradition. For example, 100800 is yi Shi Wan ling ba Bai.

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:

-123456789

Sample Output 1:

Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu

Sample Input 2:

100800

Sample Output 2:

yi Shi Wan ling ba Bai

题目大意:将数字转换成中文读法。注意stoi的使用,以及substr(i,j)的结果是得到 i 到 j-1 的子字符串。

自己需要手动输入一些测试用例,如:

测试用例: 1010010   yi Bai ling yi Wan ling yi Shi

                 1000010  yi Bai Wan ling yi Shi

                 100000000  yi Yi

                 0000  ling     

     

#include <iostream>
#include <vector>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

int main()
{
    string str;
    cin>>str;
    string a[]={"","yi","er","san","si","wu","liu","qi","ba","jiu"};
    string b[] = { "", "Shi", "Bai", "Qian", "Wan", "Shi", "Bai", "Qian", "Yi" };
    vector<string> vec;
    for(int i=str.size()-1,k=0;i>=0;i--,k++)
    {
    	if(str[i] == '0'){
    		if(k == 4){
    			string s = str.substr(0,i+1);//判断是否需要加"Wan",比如一亿
    			int n = abs(stoi(s));
    			if(n % 10000){//如101000000,需要加,100000010不需要
    				vec.push_back("Wan");
    			}
    		}
    		if(vec.empty() || vec[vec.size()-1] == "ling" || vec[vec.size()-1] == "Wan")
    		{
				continue;
    		}
    		vec.push_back("ling");
    		continue;
    	}
    	if(str[i] == '-'){
    		vec.push_back("Fu");
    		break;
    	}
        if(k)
            vec.push_back(b[k]);
        vec.push_back(a[str[i]-'0']);
    }

	for(int i=vec.size()-1;i>=0;i--)
	{
		cout<<vec[i];
		if(i != 0)
			cout<<" ";
	}
	if(vec.size() == 0)
        cout<<"ling";

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/83216356